Australis tour popup conflicts with default browser prompt to render browser unusable

RESOLVED DUPLICATE of bug 989947

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 989947
4 years ago
4 years ago

People

(Reporter: callahad, Unassigned)

Tracking

30 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8452578 [details]
australis-tour-bug.png

See attached screenshot taken with Fx 30.0 on OS X 10.9.3, with Nightly as my default browser.

When launching Firefox 30, the Australis doorhanger appears on top of the "Firefox is not your default browser" sheet, blocking clicks to the shade. However, the existence of the sheet itself blocks clicks anywhere else, *including the buttons to dismiss the Australis doorhanger.*

Steps to reproduce:

1. Set another browser as your default.
2. Start Firefox with a new profile.

What should happen:

- The default browser sheet should appear on top of the Australis doorhanger.
- I should be able to dismiss the sheet, and then interact with the doorhanger.

What actually happens:

- The doorhanger appears on top of the sheet, blocking clicks to dismiss the sheet.
- The doorhanger does not respond to any clicks, and can not be dismissed.
- The browser chrome does not respond to any clicks.
- The only things that can be clicked are the sheet's yes/no buttons, which are partially obscured by the doorhanger.

Workaround:

1. Resize the window until the sheet and doorhanger do not overlap.
2. Dismiss the sheet.
3. Continue browsing normally.

or:

1. Press "esc" to dismiss the sheet.
2. Continue browsing normally.

Comment 1

4 years ago
I would swear we had a dupe for this already but I can't find it. :-\
Component: Untriaged → General
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 989947
You need to log in before you can comment on or make changes to this bug.