[B2G][2.0][Calendar] The change to a toggle for All day events causes overlap on many languages

RESOLVED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Calendar
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: JMercado, Assigned: tchevalier)

Tracking

({regression})

unspecified
2.0 S6 (18july)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v1.4 unaffected, b2g-v2.0 fixed, b2g-v2.1 fixed)

Details

(Whiteboard: LocRun2.0)

Attachments

(3 attachments)

Created attachment 8452671 [details]
all day.png

Description:
The toggle instead of checkbox for the All Day event section of editing an event causes overlap of the text in many languages.

Prerequisites:
1) Settings > Language > Portuguese (Brazil) (pt-BR)

Repro Steps:
1) Update a Flame to 20140707000200
2) Open the Calendar
3) Press the add event button
4) Note the "All day event" text while editing the event

Actual:
Text is overlapped in multiple languages. because of the change to a toggle

Expected:
The text does not overlap with the ui.

Environmental Variables:
Device: Flame 2.0
BuildID: 20140707000200
Gaia: ef67af27dff3130d41a9139d6ae7ed640c34d922
Gecko: f53099796238
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0



Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/12612/
See attached: screenshot
This does NOT occur on 1.4 Flame.

Environmental Variables:
Device: Flame 1.4
Build ID: 20140707000200
Gaia: 5c9e1e4131d3ac8915ed88b72bb66dc7d97be6a0
Gecko: 2d0c15450488
Version: 30.0 (1.4) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

There was a check box instead of a toggle and the string did not overlap.



This issue DOES occur on 2.1 Flame and 2.0 Buri.

Environmental Variables:
Device: Flame Master
BuildID: 20140707040201
Gaia: 93daa354671a698634a3dc661c8c9dcb7d824c31
Gecko: 1dc6b294800d
Version: 33.0a1 (Master) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Environmental Variables:
Device: Buri 2.0
BuildID: 20140707000200
Gaia: ef67af27dff3130d41a9139d6ae7ed640c34d922
Gecko: f53099796238
Version: 32.0a2 (2.0) 
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


The text is overlapped by the toggle.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → unaffected
status-b2g-v2.1: --- → affected
Flags: needinfo?(ktucker)
This is a regression from 1.4 because of a visual design change. This seems minor though so I don't believe it is a blocker.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regression
Duplicate of this bug: 1036004
Duplicate of this bug: 1035921
This is a trivial fix, can do it.
Assignee: nobody → tchevalier
Status: NEW → ASSIGNED
Created attachment 8453252 [details]
Screenshot - fix pt-BR

Screenshot of the fix. Also tested with other locales.
Created attachment 8453256 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/21551

Kevin, if you have the opportunity to give it a quick look ;)
Attachment #8453256 - Flags: review?(kgrandon)
Comment on attachment 8453256 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/21551

Seems to work for me, thanks!
Attachment #8453256 - Flags: review?(kgrandon) → review+
Master: https://github.com/mozilla-b2g/gaia/commit/da5747c6108e3d8cd258e0126d6216692eeb1199
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8453256 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/21551

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): regression caused by visual redesign. Not blocking the release, but nice to have.
[User impact] if declined: The end of "All day event?" can be hidden in some locales. Meaning of the string could be altered in some cases.
[Testing completed]: tested on master w/ multiple locales
[Risk to taking this patch] (and alternatives if risky): very low
[String changes made]: no
Attachment #8453256 - Flags: approval-gaia-v2.0?(bbajaj)

Updated

4 years ago
Attachment #8453256 - Flags: approval-gaia-v2.0?(bbajaj) → approval-gaia-v2.0+
v2.0: https://github.com/mozilla-b2g/gaia/commit/97842dbea614bc55cec4c4d1dea3c443d95862aa
status-b2g-v2.0: affected → fixed
status-b2g-v2.1: affected → fixed
Target Milestone: --- → 2.0 S6 (18july)
You need to log in before you can comment on or make changes to this bug.