Closed Bug 1036240 Opened 8 years ago Closed 3 years ago

airfrance.fr sends desktop content to Firefox OS

Categories

(Web Compatibility :: Mobile, defect, P5)

Other
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.2 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.2 --- affected

People

(Reporter: karlcow, Unassigned, Mentored)

References

()

Details

(Whiteboard: [mobile-compat-form] [serversniff] [country-fr] [needscontact])

Site: http://www.airfrance.fr/
airfrance.fr sends desktop content to Firefox OS

:: Steps To Reproduce

1. With Firefox OS smartphone (Flame)
2. Go to http://www.airfrance.fr/


:: Expected Result

Receive the mobile content like Firefox on Android (http://mobile.airfrance.fr/)

:: Actual Result

receiving Desktop content

:: Additional Information

Software Version: 2.0
Device Information: Flame
Reporter's User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:32.0) Gecko/20100101 Firefox/32.0
Whiteboard: [mobile-compat-form] → [mobile-compat-form] [serversniff] [country-fr] [contactready]
# Firefox for Android gets mobile version

GET / HTTP/1.1
User-Agent:  Mozilla/5.0 (Android; Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

HTTP/1.1 301 Moved Permanently
Location: http://www.airfrance.fr/cgi-bin/AF/indexFR.jsp

Then

GET /cgi-bin/AF/indexFR.jsp HTTP/1.1
User-Agent:  Mozilla/5.0 (Android; Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

HTTP/1.1 301 Moved Permanently
Location: https://mobile.airfrance.fr?returnLink=/cgi-bin/AF/FR/fr/common/home/vols/billet-avion.do




# Firefox OS gets desktop version

GET / HTTP/1.1
User-Agent:  Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

HTTP/1.1 301 Moved Permanently
Location: http://www.airfrance.fr/cgi-bin/AF/indexFR.jsp

Then

GET /cgi-bin/AF/indexFR.jsp HTTP/1.1
User-Agent:  Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

HTTP/1.1 301 Moved Permanently
Location: /cgi-bin/AF/FR/fr/common/home/vols/billet-avion.do
Status: UNCONFIRMED → NEW
Ever confirmed: true
Previous issues with airfrance Web site are tool old (before 2003) for relevant contacts.

Sent a request through https://www.af-klm.com/passage/ecomplaints/index.html?
But it looks like a form which is more oriented towards the passenger than technical issues.

Also tried to sent an email to Tanguy Favennec
http://fr.linkedin.com/in/tanguyfavennec
Assignee: nobody → kdubost
Mentor: kdubost
Status: NEW → ASSIGNED
Whiteboard: [mobile-compat-form] [serversniff] [country-fr] [contactready] → [mobile-compat-form] [serversniff] [country-fr] [sitewait]
Automatic reply for the form
RE: Case Number 13076869

> We assure you we will reply within 30 days. Please know 
> we strive to meet a goal of responding within 7 days, 
> however, due to the complexity of some correspondence, 
> we may need additional time to respond and appreciate 
> your patience.
We got an answer by email, acknowledging the issue. 
I will followup today.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Firefox OS is still not receiving the mobile Web site.
With iOS 8, an intermediate screen proposes to select in between mobile and desktop.
The Web site  https://mobile.airfrance.fr/ is working well on Firefox OS.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Duplicate of this bug: 1143450
Still receiving the desktop site. 
Switching back to needscontact.
Whiteboard: [mobile-compat-form] [serversniff] [country-fr] [sitewait] → [mobile-compat-form] [serversniff] [country-fr] [needscontact]
Priority: -- → P5
The Firefox OS project is not active anymore at Mozilla.
Assignee: kdubost → nobody
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.