Support for adding effort figures to trouble tickets missing

RESOLVED DUPLICATE of bug 24789

Status

()

Bugzilla
Creating/Changing Bugs
--
enhancement
RESOLVED DUPLICATE of bug 24789
17 years ago
6 years ago

People

(Reporter: mschmitz, Assigned: myk)

Tracking

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
The patch attached to the trouble ticket allows to associated effort figures
(planned, real and remaining) with a bug report. Group bits can used to     
restrict access to this fields (no access, read-only access, read/write access).
This concerns not only the bug form, but also the activities log and the mail
sent out when the trouble ticket changes. The feature can be disabled in the
parameter section.
(Reporter)

Comment 1

17 years ago
Created attachment 52497 [details] [diff] [review]
Effort Figures Patch
(Reporter)

Comment 2

17 years ago
I had to add fix the query form since the list of attributes displayed in the
"Where the field(s)" selection list contains the *_effort fields even for users
that don't have access to these fields. Look at the "Effort Figures Query Patch"
for the necessary modifications.
(Reporter)

Comment 3

17 years ago
Created attachment 52708 [details] [diff] [review]
Effort Figures Query Patch
(Reporter)

Comment 4

17 years ago
The third patch - the Effort figures Buglist Patch - fixes problems with the
effort figures attributes in the bug list:

  1.  The corresponding fields didn't appear in output you get when pressing the
      "Long Format" button.
  2.  The same applies to the "Change Columns" dialog.
(Reporter)

Comment 5

17 years ago
Created attachment 52909 [details] [diff] [review]
Effort Figures Buglist Patch
Keywords: patch, review
Target Milestone: --- → Bugzilla 2.16
We are currently trying to wrap up Bugzilla 2.16.  We are now close enough to
release time that anything that wasn't already ranked at P1 isn't going to make
the cut.  Thus this is being retargetted at 2.18.  If you strongly disagree with
this retargetting, please comment, however, be aware that we only have about 2
weeks left to review and test anything at this point, and we intend to devote
this time to the remaining bugs that were designated as release blockers.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18

Comment 7

17 years ago
It's been a while since the last announcement. Is this feature still targeted
for 2.18?

Comment 8

17 years ago
What about bug 24789? Isn't it something similar?
(Reporter)

Comment 9

17 years ago
Yes, Andreas, you're right, it is similar to bug 24789. The one main difference
I can see is, that my patch includes support for access restrictions, which is
indispensable in my opinion.
This is, however, still a dupe of bug 24789 - if you want additional access
controls, then please comment in that bug.

*** This bug has been marked as a duplicate of 24789 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
clearing target in DUPLICATE/WORKSFORME/INVALID/WONTFIX bugs so they'll show up
as untriaged if they get reopened.
Target Milestone: Bugzilla 2.18 → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.