[Flame][Master::v2.1] Auto-focus triggers flash light

RESOLVED DUPLICATE of bug 1036312

Status

RESOLVED DUPLICATE of bug 1036312
4 years ago
4 years ago

People

(Reporter: whsu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8453036 [details]
WP_20140709_002.mp4

* Description:
  Turning on the flash light and try to focus something, you will see the flash light keep flash.
  I can reproduce this bug on Master build(v2.1) but I "cannot" reproduce it on latest V2.0 build.
  Attach the demo video. (WP_20140709_002.mp4)

* Reproduction steps:
  1. Launch the camera app then turn on the flash light
  2. focusing something

* Expected result:
  The behavior triggers the auto-focus

* Actual result:
  The flash light keeps flash

* Reproduction build: Master::V2.1 (Flame)
  - Gaia      740faa5d0060fb218b407cf224330654ddf833a5
  - Gecko     https://hg.mozilla.org/mozilla-central/rev/d35c1bf0f084
  - BuildID   20140708160204
  - Version   33.0a1
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.1?
(Reporter)

Comment 1

4 years ago
Add a additional information.
v2.0: Manual focus (Tap screen) will trigger flash light.
v2.1: Manual focus and auto-focus will trigger flash light.
See also bug 1036312, which shows the same symptoms, even when the camera is in the background, and even while the screen is off.
See Also: → bug 1036312
(Reporter)

Comment 3

4 years ago
(In reply to Mike Habicher [:mikeh] from comment #2)
> See also bug 1036312, which shows the same symptoms, even when the camera is
> in the background, and even while the screen is off.

Yes! I also see the symptoms. Thanks!
Have a nice day!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1036312

Updated

4 years ago
blocking-b2g: 2.1? → ---
You need to log in before you can comment on or make changes to this bug.