Closed Bug 1036731 Opened 5 years ago Closed 5 years ago

[B2G][Settings] Hyperlinks in "App Permissions" incorrectly redirect the user to https://github.com/mozilla-b2g/gaia

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.4+, b2g-v1.3 unaffected, b2g-v1.3T unaffected, b2g-v1.4 unaffected, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S6 (18july)
blocking-b2g 1.4+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- unaffected
b2g-v1.4 --- unaffected
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: dharris, Assigned: arthurcc)

References

()

Details

(Keywords: regression, Whiteboard: [273MB-Flame-Support][2.0-exploratory][p=1])

Attachments

(3 files)

Attached file Wrong Hyperlink.txt
Description:
If the user installs an app and then selects the hyperlink under "Author" in the App Permissions for that app, they will always be taken to https://github.com/mozilla-b2g/gaia

Prerequisite: Have an app that has permissions installed from the marketplace (Facebook). Be connected to Wifi

Repro Steps:
1) Update a Flame to Build ID: 20140707000200
2) Open Settings App> App permissions
3) Tap on the app installed from the Marketplace (Facebook)
4) Observe the Hyperlink below "Author"> Tap the Hyperlink

Actual:
The user is taken to the Gaia Github page, instead of the hyperlink that is shown
(Gaia Page: https://github.com/mozilla-b2g/gaia)

Expected:
User is taken to the website that is shown in the hyperlink

Flame 2.0

Environmental Variables:
Device: Flame 2.0 (273mb)
Build ID: 20140708000322
Gaia: e935f4ff190b76c70d9b2af8856c542a6e4a7546
Gecko: 3f9d7a3a0b7b
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Keywords: Redirected, Taken, Moved, Text, Hyperlink

Repro frequency: 100%
See attached: Logcat, Video - http://youtu.be/dg7_7Hv9L2g
This issue DOES occur on Flame 2.1, Buri 2.1, Flame 2.0 (512mb) Buri 2.0, Flame 1.4, and Buri 1.4

The user is taken to https://github.com/mozilla-b2g/gaia when selecting the Author hyperlink in App Permissions


Flame 2.1

Environmental Variables:
Device: Flame Master
Build ID: 20140709040203
Gaia: 0f9f11d0a6dadb3ea27160204bbe911c1ad69a6f
Gecko: 196d05832e12
Version: 33.0a1 (Master) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Buri 2.1

Environmental Variables:
Device: Buri Master
Build ID: 20140709073020
Gaia: c394b7b4205b6f1a6ca44915fc08650f3ad127ec
Gecko: 2d88803a0b9c
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Flame 2.0 (512mb)

Environmental Variables:
Device: Flame 2.0
BuildID: 20140708000322
Gaia: e935f4ff190b76c70d9b2af8856c542a6e4a7546
Gecko: 3f9d7a3a0b7b
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140709063007
Gaia: 1774027323bb072b4ebdfea9883572bcf2535c87
Gecko: 11b6493a7d8f
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Flame 1.4

Environmental Variables:
Device: Flame 1.4
Build ID: 20140709003002
Gaia: b0e9b4bdb39c5eb93a6783a34624ffc84f62b126
Gecko: acf704e54e19
Version: 30.0 (1.4) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Buri 1.4

Environmental Variables:
Device: Buri 1.4
Build ID: 20140709003002
Gaia: b0e9b4bdb39c5eb93a6783a34624ffc84f62b126
Gecko: acf704e54e19
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


This issue does NOT occur on Buri 1.3

If the user select the www.facebook.com hyperlink, they are taken to Facebook sign in page

Environmental Variables:
Device: Buri 1.3
Build ID: 20140709024000
Gaia: 23f55be856cef53c6604a6fe4aeb09061afbc897
Gecko: 601d27e413a9
Version: 28.0 (1.3) MOZ
Firmware Version: v1.2device.cfg
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
The Flame 2.1 and 1.4 tests were done with 273mb memory
Keywords: regression
Did you test other 3rd party apps besides Facebook on Buri 1.3?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(dharris)
Yes, Loqui IM, MessageMe, ConnectA2 and CutTheRope all redirect the user to the proper website with the Hyperlink given under "Author"
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
Flags: needinfo?(dharris) → needinfo?(ktucker)
This issue seems like a minor regression. However, I don't know how partners would feel about these links not redirecting the user to their sites?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(In reply to ktucker from comment #5)
> This issue seems like a minor regression. However, I don't know how partners
> would feel about these links not redirecting the user to their sites?

I don't think I agree. Content partners would be quite upset if the developer links to their sites weren't working in Firefox OS.

We should block here for 2.0 & get Wayne to weigh in here if he thinks this will block Dolphin.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(wchang)
blocking-b2g: 2.0? → 2.0+
QA Contact: pcheng
From my point of view this should be blocking but the device makers are probably less concerned about this than the app developers.

I would say the marketplace team would be more concerned here since they will be dealing with the developer partners.

ni? Thomas Elin and David Alstrom
Flags: needinfo?(wchang)
Flags: needinfo?(telin)
Flags: needinfo?(dalmstrom)
Assignee: nobody → arthur.chen
Whiteboard: [273MB-Flame-Support][2.0-exploratory] → [273MB-Flame-Support][2.0-exploratory][p=1][ETA: 7/16]
Target Milestone: --- → 2.0 S6 (18july)
blocking-b2g: 2.0+ → 1.4?
EJ, could you help review this simple patch? Thanks.
Attachment #8455991 - Flags: review?(ejchen)
Status: NEW → ASSIGNED
I tend to agree; the developers will for sure not be happy if users are rerouted to github. Thomas?
Flags: needinfo?(dalmstrom)
blocking-b2g: 1.4? → 1.4+
Comment on attachment 8455991 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/21739

Thanks Arthur,

based on our offline discussions, please add one more unit test for this case !

And because there is no AMD refactor on v1.4, we have to provide another patch for it. Thanks !!
Attachment #8455991 - Flags: review?(ejchen)
Comment on attachment 8455991 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/21739

Test added. EJ, could you help review it again? Thanks.
Attachment #8455991 - Flags: review?(ejchen)
I'm able to reproduce this on master and v2.0 but not v1.4 with Flame. Mark qawanted for v1.4.

Gaia      393d72937727ad20e82b2ff7b13e3d7ff077a9f0
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/932c37978d37
BuildID   20140715160201
Version   30.0
ro.build.version.incremental=eng.cltbld.20140602.192604
ro.build.date=Mon Jun  2 19:26:18 EDT 2014
B1TC400110G0
Keywords: qawanted
Comment on attachment 8455991 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/21739

r+, thanks for the work, Arthur !
Attachment #8455991 - Flags: review?(ejchen) → review+
Thanks, EJ!

master: bdadd6a0590d842fa085ec29c7b2d2ce6beb6dd9
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Needs rebasing for v1.4 uplift. Also, needinfo bajaj? on whether this should go onto v2.0 or not.
Flags: needinfo?(bbajaj)
Flags: needinfo?(arthur.chen)
v2.0: https://github.com/mozilla-b2g/gaia/commit/2d9a92f0d5f272dce0eabcde81d18bd0b116063a
Flags: needinfo?(bbajaj)
Whiteboard: [273MB-Flame-Support][2.0-exploratory][p=1][ETA: 7/16] → [273MB-Flame-Support][2.0-exploratory][p=1]
Issue is resolved, removing QA-Wanted keywords
Joshua, do you mean the issue is resolved on v1.4?
Flags: needinfo?(jmitchell)
(In reply to Arthur Chen [:arthurcc] from comment #18)
> Joshua, do you mean the issue is resolved on v1.4?

sorry, no.  I meant to say that this issue has been marked "resolved-fixed" and patches are submitted so doing a regression-window at this point would be a waste of resources.
Flags: needinfo?(jmitchell)
Mark fixed on v1.4 as I am not able to reproduce the bug as described in comment 12. There would be no uplift to v1.4 needed.
Flags: needinfo?(arthur.chen)
Flags: needinfo?(telin)
Attached video video
This issue has been verified successfully on Flame 2.0 and 2.1
See attachment: Verify_1036731.MP4
Reproducing rate: 0/3
Reproducing steps:
Precondition: Flame RAM is adjusted as 273MB
1.Launch Marketplace and install Facebook app
2.Open Settings App> App permissions
3.Tap on the Facebook app
4.Tap the Hyperlink below "Author"
** User is taken to the Facebook log in website.

Flame 2.0 build:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141201000201
Version         32.0

Flame2.1 build:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141201001201
Version         34.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.