Closed Bug 1037081 Opened 6 years ago Closed 6 years ago

Tree row is no longer sortable in content preferences sub dialog

Categories

(Firefox :: Preferences, defect)

33 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 33
Iteration:
33.3
Tracking Status
firefox33 - verified

People

(Reporter: alice0775, Assigned: Paenglab)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Steps To Reproduce:
1. Open in-content preferences
2. Open any sub dialog such as [Password manager], [Exceptions dialog]

Actual Results:
In content preferences sub dialog, Tree row is no longer sortable.

Expected Results:
Tree row should be sortable.
Blocks: 752197, ship-incontent-prefs
No longer blocks: 996920
QA Whiteboard: [qa+]
Flags: firefox-backlog+
In fact it seems it's still sortable but only with right click.
Attached patch treecol.patch (obsolete) — Splinter Review
Override http://mxr.mozilla.org/mozilla-central/source/browser/themes/shared/incontentprefs/preferences.css#19
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8454926 - Flags: review?(MattN+bmo)
Comment on attachment 8454926 [details] [diff] [review]
treecol.patch

Review of attachment 8454926 [details] [diff] [review]:
-----------------------------------------------------------------

I can't say I'm a fan of the "*" and wonder if there are going to be other behaviours that are broken because of the -moz-user-select.

::: browser/themes/shared/incontentprefs/preferences.css
@@ +754,5 @@
>    }
>  }
>  
> +treecol {
> +  -moz-user-select: none;

r=me if you move this new block directly below the "*" block:
* {
  -moz-user-select: text;
}

and add a comment under treecol explaining that this is so columns are sortable.
Attachment #8454926 - Flags: review?(MattN+bmo) → review+
Addressed the comment
Attachment #8454926 - Attachment is obsolete: true
Attachment #8455191 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/c274ab1b4086
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
Iteration: --- → 33.3
QA Contact: camelia.badau
Verified on Windows 7 32bit and Windows 7 64bit using latest Nightly 33.0a1 (buildID: 20140715030207) and the following mention should be done: 
- under Security tab -> "Saved Passwords" sub dialog -> if I perform right click on any sort preferences (e.g: site, username), the Context Menu (with "Copy Username", "Copy Password" options) is displayed, but the rows are also sorted -> It is ok? Is this behaviour intented?
Flags: needinfo?(richard.marti)
This happens also in normal dialog preferences (and also in TB). I would say this isn't intended but not caused by this bug.

Best is if you file a bug.
Flags: needinfo?(richard.marti)
I filled bug 1039540 .
Status: RESOLVED → VERIFIED
QA Whiteboard: [qa+] → [qa!]
You need to log in before you can comment on or make changes to this bug.