Closed Bug 1037345 Opened 5 years ago Closed 3 years ago

[Email] Error message should indicate protocol on login failure

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 affected, b2g-v2.1 ?)

RESOLVED WONTFIX
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- ?

People

(Reporter: gerard-majax, Unassigned)

References

Details

(Keywords: foxfood)

When the user configures the email account, the application will perform some checking. This may result in an error message if the credentials are wrong.

As far as I can say and I could reproduce on recent aurora builds of B2G, the error message does not states whether the error came from IMAP or SMTP for example. This may be very problematic if the user has a different set of login/password for IMAP/SMTP.
Good point.  We improved the bad password dialog to convey the protocol in use when we get a bad password, but the initial account setup does not do this.

From a prioritization perspective, I think "very problematic" might be over-emphasizing it since I expect most servers will use the same credentials and all email clients will require manual setup if different credentials will be used.

I guess one question is whether we should do different things on the autoconfig screen versus the manual config screen.  On autoconfig we might want to say something like "hey, the IMAP part says the password is good, but the SMTP part says it's bad, maybe you want to use manual setup? (but less technically.)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.