Closed Bug 1037438 Opened 5 years ago Closed 3 years ago

implement 'Never Share' persistent permissions for screen sharing

Categories

(Firefox :: Site Permissions, defect)

defect
Not set
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 53
Tracking Status
firefox53 --- verified

People

(Reporter: florian, Assigned: florian)

References

Details

(Whiteboard: [fxprivacy])

Attachments

(1 file)

It makes no sense to have an "Always share" action for screensharing, because the user needs to select each time which application will be shared, but it would make sense for the user to have a way to never be bothered again by a specific website showing the screensharing prompt.
Flags: firefox-backlog+
Blocks: 1035577
Depends on: 1037405
QA Whiteboard: [qa?]
QA Whiteboard: [qa?] → [qa+]
QA Whiteboard: [qa+]
Flags: qe-verify+
Depends on: 1048209
Bug 1282768 exposed this in the UI without actually implementing it. I'm rediscovering this now that I'm writing a test to cover the UI in bug 1313324.
Assignee: nobody → florian
Blocks: 1282768, 1313324
Component: General → Device Permissions
Whiteboard: [fxprivacy][triage]
Attached patch PatchSplinter Review
The associated test is coming in bug 1313324.
Attachment #8814477 - Flags: review?(rjesup)
Attachment #8814477 - Flags: review?(past)
Attachment #8814477 - Flags: review?(rjesup) → review+
Attachment #8814477 - Flags: review?(past) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/ca8ca07756ab80d29778329aa22ebc453f17fc69
Bug 1037438 - implement persistent deny permissions for screen sharing, r=jesup,past.
backed this out in https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=670ad168fb708a7eca83480419f6206833b2566e because of continued test failures like https://treeherder.mozilla.org/logviewer.html#?job_id=39930510&repo=mozilla-inbound

maybe this need a try run to find out what was going wrong
Flags: needinfo?(florian)
Whiteboard: [fxprivacy][triage] → [fxprivacy]
https://hg.mozilla.org/integration/mozilla-inbound/rev/6992281f395d344cf6921297ecf83fe8df071188
Bug 1037438 - implement persistent deny permissions for screen sharing, r=jesup,past.
Flags: needinfo?(florian)
https://hg.mozilla.org/mozilla-central/rev/6992281f395d
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Steps to reproduce:
1. Load https://mozilla.github.io/webrtc-landing/gum_test.html
2. Click "Screen"
3. In the prompt, check the "Remember this decision" checkbox, and click the "Don't Allow" button.
4. Reload the page, and click the "Screen" button again.

Expected result: no prompt should appear.
(In reply to Florian Quèze [:florian] [:flo] from comment #8)
> Steps to reproduce:
> 1. Load https://mozilla.github.io/webrtc-landing/gum_test.html
> 2. Click "Screen"
> 3. In the prompt, check the "Remember this decision" checkbox, and click the
> "Don't Allow" button.
> 4. Reload the page, and click the "Screen" button again.
> 
> Expected result: no prompt should appear.

This was incomplete sorry; I had forgotten that before this fix the screensharing permission was incorrectly saved as a camera permission.

Add the following step:
5. Click the "Camera" button.

Expected result: we should prompt the user to share the camera.
Actual result without the fix: the camera request was denied immediately.
Tested on Mac OS X 10.10, Windows 10 x64, Ubuntu 16.04 x64 with Nighlty 53.0a1(2016-12-19) and I can confirm the fix, the user is prompted to share the camera.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.