Badged buttons broke Panel UI if moved inside

RESOLVED DUPLICATE of bug 1029937

Status

()

defect
RESOLVED DUPLICATE of bug 1029937
5 years ago
4 years ago

People

(Reporter: zer0, Unassigned)

Tracking

Trunk
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

The Panel UI doesn't work properly once a badged button is moved there, in customization mode.

Step to reproduce:

1. Enter in costumization mode
2. Move a badged button from the navbar to Panel UI (be sure the button as a badge displayed)
3. Exit from costumization mode
4. Try to open Panel UI

At least in OS X, the first attempt to open the Panel UI fails – it's close immediately. The second attempt, shows the Panel UI without the middle part – the area where the icons are.

Expected result:
The Panel UI should be open as usual.


To reproduce easily the scenario, here the code to create a customizable badged button (execute in scratchpad, browser env.):

  CustomizableUI.createWidget({
    id: 'test-button',
    type: 'custom',
    removable: true,
    defaultArea: CustomizableUI.AREA_NAVBAR,
    onBuild: function(aDocument) {
      let node = aDocument.createElement('toolbarbutton');
      node.id = this.id;
      node.setAttribute('class', 'toolbarbutton-1 chromeclass-toolbar-additional social-status-button');
      node.style.listStyleImage = "url(resource:///chrome/browser/skin/classic/browser/Geolocation-16.png)";
      node.setAttribute("type", "badged");
      node.setAttribute("badge", "1");
      node.setAttribute("label", "button");
      return node;
    }
  });

And then follow the steps described at the beginning.

Updated

5 years ago
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1029937
You need to log in before you can comment on or make changes to this bug.