Anchor element not-in-document should still have activation behavior

RESOLVED DUPLICATE of bug 1218456

Status

()

defect
RESOLVED DUPLICATE of bug 1218456
5 years ago
2 years ago

People

(Reporter: smaug, Unassigned)

Tracking

29 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Currently
var a = document.createElement("a");
a.href = "http://www.mozilla.org";
a.click();
doesn't work, but per spec it should.

http://www.whatwg.org/specs/web-apps/current-work/#following-hyperlinks-2
("Let source be the browsing context that contains the Document object with which subject in question is associated." is vague, but will be fixed https://www.w3.org/Bugs/Public/show_bug.cgi?id=26310 )
Note that I expect we have old bugs on this that will need dupping forward.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1218456
You need to log in before you can comment on or make changes to this bug.