Closed Bug 1037827 Opened 5 years ago Closed 5 years ago

Intermittent test_play_ogg_video.py TestPlayOGGVideo.test_play_ogg_video | AssertionError: time.struct_time(tm_year=1900, tm_mon=1, tm_mday=1, tm_hour=0, tm_min=0, tm_sec=0, tm_wday=0, tm_yday=1, tm_isdst=-1) not greater than time.struct_time(tm_year=1900

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

x86_64
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: RyanVM, Unassigned)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=43674980&tree=Mozilla-Inbound

b2g_macosx64 mozilla-inbound opt test gaia-ui-test on 2014-07-11 23:46:19 PDT for push 7dd2566f4349
slave: talos-mtnlion-r5-037

00:09:16     INFO -  TEST-START | test_play_ogg_video.py TestPlayOGGVideo.test_play_ogg_video
00:09:28    ERROR -  TEST-UNEXPECTED-FAIL | test_play_ogg_video.py TestPlayOGGVideo.test_play_ogg_video | AssertionError: time.struct_time(tm_year=1900, tm_mon=1, tm_mday=1, tm_hour=0, tm_min=0, tm_sec=0, tm_wday=0, tm_yday=1, tm_isdst=-1) not greater than time.struct_time(tm_year=1900, tm_mon=1, tm_mday=1, tm_hour=0, tm_min=0, tm_sec=0, tm_wday=0, tm_yday=1, tm_isdst=-1)
00:09:28     INFO -  Traceback (most recent call last):
00:09:28     INFO -    File "/builds/slave/talos-slave/test/build/venv/lib/python2.7/site-packages/marionette/marionette_test.py", line 171, in run
00:09:28     INFO -      testMethod()
00:09:28     INFO -    File "/builds/slave/talos-slave/test/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/videoplayer/test_play_ogg_video.py", line 42, in test_play_ogg_video
00:09:28     INFO -      self.assertGreater(fullscreen_video.elapsed_time, zero_time)
00:09:28     INFO -  TEST-INFO expected PASS | took 11512ms
Attached image video_time.png
I was able to reproduce this issue locally, but only with automated tests. Had no luck with manual testing. 
It looks like the elapsed time text displays 00:00 even though the progress bar shows that the video has started. (The test waits 2 seconds between taping on the video and getting the elapsed time text)

This issue has been reproduced using other file formats too. I have attached a screenshot of the failure from a Jenkins test run.

Build info v2.0 flame:
Device firmware (date) 	27 Jun 2014 00:57:58
Device firmware (incremental) 	110
Device firmware (release) 	4.3
Device identifier 	flame
Gaia date 	12 Aug 2014 13:36:31
Gaia revision 	6155d46822ed
Gecko build 	20140812160201
Gecko revision 	017e9d274f08
Gecko version 	32.0
Is Bug 976028 the same issue?
This is working fine now.


Please reopen if this is failing
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
QA Whiteboard: [fxosqa-auto-s1]
You need to log in before you can comment on or make changes to this bug.