No precedence control for settings in new sync (sync 1.5)

RESOLVED DUPLICATE of bug 966530

Status

()

RESOLVED DUPLICATE of bug 966530
5 years ago
4 years ago

People

(Reporter: phil.tooley, Unassigned)

Tracking

30 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

New sync version does not seem to correctly handle precedence for customised settings.

Example:

1. Delete %appdata%/mozilla on both machines.
2. Open ff on laptop, set up new sync account
3. In about:config set browser.newtab.url="about:blank"
4. Set services.sync.prefs.sync.browser.newtab.url=true
5. Sync now to be sure settings uploaded

6. Open ff on desktop
7. Log in to sync account.

Back with the old sync I was always able to do a full overwrite and this never happened, but now some strange mangling together of the settings is occurring.

Can the old feature be re-added to allow complete overwrite of local data with server settings? Otherwise adding a new browser to an existing set of set up browsers will play havoc with customisations.



Actual results:

settings on desktop become:
        services.sync.prefs.sync.browser.newtab.url=true
        browser.newtab.url="about:newtab"

settings on laptop reset to:
        browser.newtab.url="about:newtab"


Expected results:

settings on desktop become:
        services.sync.prefs.sync.browser.newtab.url=true
        browser.newtab.url="about:blank"

settings on laptop unchanged

Updated

4 years ago
Component: Untriaged → Sync
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 966530
You need to log in before you can comment on or make changes to this bug.