Test failure 'Autocomplete results should be visible' in testAwesomeBar/testAccessLocationBar.js

RESOLVED FIXED

Status

defect
P1
normal
RESOLVED FIXED
5 years ago
2 months ago

People

(Reporter: danisielm, Assigned: andrei)

Tracking

(Depends on 1 bug, {regression})

Dependency tree / graph

Firefox Tracking Flags

(firefox33 fixed, firefox34 fixed)

Details

(Whiteboard: [mozmill-test-failure], )

Attachments

(2 attachments)

Module:    functional
Test:      testAwesomeBar/testAccessLocationBar.js > testAccessLocationBarHistory
Failure:   Autocomplete results should be visible
Branches:  Nightly
Platforms: OSX (all)

Line that fails: https://hg.mozilla.org/qa/mozmill-tests/file/a59e61505aef/firefox/tests/functional/testAwesomeBar/testAccessLocationBar.js#l57

I can reproduce this locally on my Mac OSX 10.8. Looks like it only affects OSX.

It started from the build since 12 July 2014:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e1a037c085d1&tochange=b0701d069bf9

As the most candidate I see bug 1020496 to cause this.
Posted patch skip.patchSplinter Review
Attachment #8455299 - Flags: review?(andrei.eftimie)
Attachment #8455299 - Flags: review?(andreea.matei)
Comment on attachment 8455299 [details] [diff] [review]
skip.patch

Review of attachment 8455299 [details] [diff] [review]:
-----------------------------------------------------------------

Disabled:
https://hg.mozilla.org/qa/mozmill-tests/rev/84ba064c9daa (default)

We should check if there's a way to also add a message when conditionally disabling tests.
I know I've searched for a way some while ago but didn't found one.
Attachment #8455299 - Flags: review?(andrei.eftimie)
Attachment #8455299 - Flags: review?(andreea.matei)
Attachment #8455299 - Flags: review+
Attachment #8455299 - Flags: checkin+
Assignee: nobody → andrei.eftimie
Status: NEW → ASSIGNED
Pushlog: https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=1829aad143e2&tochange=4ce737d7339d

Regressor is bug 1034845

Checking now exactly what fails in our test and why.
I can reproduce this manually:

1. Open Firefox (preferably a populated profile, otherwise visit some pages)
2. In an existing or new tab type in "about:blank"
3. Hit the down arrow once

Expected result: the AutoComplete popup opens
Actual result: nothing happens

==

Both: "about:blank", "about:newtab" are affected.

Dao, could you please look into your patch from bug 1034845 could have affected this?
Thanks.
Flags: needinfo?(dao)
Sorry, I don't see how my patch from bug 1034845 would cause this, let alone why it would be OS-X-only.
Flags: needinfo?(dao)
This is certainly a regression in Firefox. Andrei, please file a new bug under the appropriate component for further investigation. Lets not hijack again one of our bugs under mozmill-tests.
Depends on: 1038614
From what I see in bug 1038614, it's not a big issue for them to get fixed, so not sure if we want to keep this as P1 and also not have the test fixed (even if it's kind of a workaround) so we can use it. Since they don't think this is major to get fixed, we'll have this test skipped for a year or more :(
I agree, lets get this fixed with a workaround and mark 1038614 as a potential fix to remove the workaround
Works fine to blur the urlbar before attempting to clear it.
Attachment #8476538 - Flags: review?(andreea.matei)
Comment on attachment 8476538 [details] [diff] [review]
workaround.patch

Review of attachment 8476538 [details] [diff] [review]:
-----------------------------------------------------------------

http://hg.mozilla.org/qa/mozmill-tests/rev/78a4050ea9dd (default)

I'll leave it until tomorrow before backporting to aurora.
Attachment #8476538 - Flags: review?(andreea.matei) → review+
All good, transplanted:
http://hg.mozilla.org/qa/mozmill-tests/rev/b21a411fe07d (aurora)
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.