loadimageSSE2.cpp: Cannot open include file: 'd3dcompiler.h' with --disable-angle + --disable-webgl

RESOLVED DUPLICATE of bug 1037667

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1037667
4 years ago
4 years ago

People

(Reporter: gcp, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
17:04.47 The following command failed to execute properly:
17:04.47 e:/mozilla/mozilla-central/objdir-desktop/_virtualenv/Scripts/python.ex
e -m mozbuild.action.cl cl -FoloadimageSSE2.obj -c -DNOMINMAX -D_CRT_SECURE_NO_D
EPRECATE -D_HAS_EXCEPTIONS=0 -DANGLE_ENABLE_D3D9 -DANGLE_ENABLE_D3D11 -DANGLE_CO
MPILE_OPTIMIZATION_LEVEL=D3DCOMPILE_OPTIMIZATION_LEVEL1 -DANGLE_NO_EXCEPTIONS -D
GL_APICALL= -DGL_GLEXT_PROTOTYPES= -DEGLAPI= -DANGLE_PRELOADED_D3DCOMPILER_MODUL
E_NAMES={ TEXT("d3dcompiler_47.dll"), TEXT("d3dcompiler_46.dll"), TEXT("d3dcompi
ler_43.dll") } -DNO_NSPR_10_SUPPORT -Ie:/mozilla/mozilla-central/gfx/angle/src/l
ibGLESv2 -I. -Ie:/mozilla/mozilla-central/gfx/angle/src/libGLESv2/../../include
-Ie:/mozilla/mozilla-central/gfx/angle/src/libGLESv2/../../src -I../../../../dis
t/include -Ie:/mozilla/mozilla-central/objdir-desktop/dist/include/nspr -Ie:/moz
illa/mozilla-central/objdir-desktop/dist/include/nss -I/e/mozilla/mozilla-centra
l/objdir-desktop/dist/include -I/e/mozilla/mozilla-central/modules/zlib/src -MD
-FI ../../../../dist/include/mozilla-config.h -DMOZILLA_CLIENT -TP -nologo -D_HA
S_EXCEPTIONS=0 -W3 -Gy -wd4251 -wd4244 -wd4345 -wd4351 -wd4482 -wd4800 -wd4819 -
we4553 -GR- -DDEBUG -DTRACING -Zi -O1 -Oi -Oy- -Fdgenerated.pdb e:/mozilla/mozil
la-central/gfx/angle/src/libGLESv2/renderer/loadimageSSE2.cpp
17:04.47 e:/mozilla/mozilla-central/config/rules.mk:992: recipe for target 'load
imageSSE2.obj' failed

17:04.45 e:\mozilla\mozilla-central\gfx\angle\src\libGLESv2\precompiled.h(39) :
fatal error C1083: Cannot open include file: 'd3dcompiler.h': No such file or di
rectory

My .mozconfig has both --disable-angle and --disable-webgl, but this still seems to end up including parts of angle.
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1037667
You need to log in before you can comment on or make changes to this bug.