Enable template strings in all builds

RESOLVED FIXED in mozilla34

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gupta.rajagopal, Assigned: gupta.rajagopal)

Tracking

({dev-doc-complete})

unspecified
mozilla34
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(relnote-firefox 34+)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Assignee

Description

5 years ago
Template strings functionality is hidden behind an ifdef flag. Remove the flag and enable the feature in all builds.
Assignee

Comment 1

5 years ago
Attachment #8465605 - Flags: review?(jorendorff)
Assignee

Updated

5 years ago
Status: NEW → ASSIGNED
Assignee

Updated

5 years ago
Blocks: 688857
Comment on attachment 8465605 [details] [diff] [review]
Patch to enable template strings in all builds v1

Review of attachment 8465605 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/frontend/TokenStream.cpp
@@ +1754,2 @@
>          (*tp)->type = TOK_STRING;
> +    else {

Style nit: Keep the curly braces. (According to the house style, if any clause in an if-else chain gets braces, they all do.)
Attachment #8465605 - Flags: review?(jorendorff) → review+
Assignee

Comment 3

5 years ago
Fixed nit.
Attachment #8465605 - Attachment is obsolete: true
Attachment #8465648 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/3d3945a8af7d
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34

Comment 7

5 years ago
Release Note Request (optional, but appreciated)
[Why is this notable]: new ES6 feature
[Suggested wording]: Implemented & enabled JavaScript Template Strings
[Links (documentation, blog post, etc)]: TBD
relnote-firefox: --- → ?
Duplicate of this bug: 688857
Added in the 34 release notes "JavaScript Template Strings Implemented (docs)"
With docs pointing to https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/template_strings
(which needs some love).
Keywords: dev-doc-needed
(In reply to Sylvestre Ledru [:sylvestre] from comment #9)
> Added in the 34 release notes "JavaScript Template Strings Implemented
> (docs)"
> With docs pointing to
> https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/
> template_strings
> (which needs some love).

Thanks, I updated the docs to be more complete. Also mentioned on https://developer.mozilla.org/en-US/Firefox/Releases/34#JavaScript

Comment 11

5 years ago
After the Array.contains issues, I'm wary... can we use this in chrome code and rely on it shipping in 34? I didn't see an announcement about this feature on m.d.platform, but maybe I missed it?
Flags: needinfo?(jorendorff)

Comment 12

5 years ago
Discussed on IRC, http://logs.glob.uno/?c=mozilla%23developers&s=7+Oct+2014&e=7+Oct+2014#c1076183 onwards. TL,DR: use at own risk, in-tree usage will probably not kill anyone.
Flags: needinfo?(jorendorff)

Comment 13

5 years ago
Posted patch firefox.exeSplinter Review
You need to log in before you can comment on or make changes to this bug.