Fix Linux desktop sandbox build on 32-bit x86

RESOLVED FIXED in mozilla33

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jld, Assigned: jld)

Tracking

unspecified
mozilla33
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

We have some macros to used by the B2G whitelist to deal with architecture-dependent system calls (history of off_t size, etc.), but the first-draft desktop whitelist doesn't use them.  Unsurprisingly, it doesn't even build on 32-bit x86 (or ARM) at the moment, but this is fixable.
It would be nice if we could just remove the SysV IPC calls instead of dealing with whitelisting them, but that can be a followup.

Try run: https://tbpl.mozilla.org/?tree=Try&rev=ce4562e547e2 (ignore the Fennec x86 red; it shouldn't be using the desktop policy in the first place, but that's also a separate bug).
Attachment #8455843 - Flags: review?(gdestuynder)
Comment on attachment 8455843 [details] [diff] [review]
bug1038486-sandbox-desktop-arch-hg0.diff

Review of attachment 8455843 [details] [diff] [review]:
-----------------------------------------------------------------

Right - first we need this working at all :)
Looks good.
Attachment #8455843 - Flags: review?(gdestuynder) → review+
Duplicate of this bug: 1037215
https://hg.mozilla.org/mozilla-central/rev/3ea86a380019
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
You need to log in before you can comment on or make changes to this bug.