bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

N620 Trunk LDAP connection crash [@ nsLDAPConnection::OnFound]

VERIFIED DUPLICATE of bug 102227

Status

Directory
LDAP XPCOM SDK
--
critical
VERIFIED DUPLICATE of bug 102227
17 years ago
16 years ago

People

(Reporter: greer, Assigned: dmose)

Tracking

({crash, topcrash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

17 years ago
Talkback is getting crash notices at nsLDAPConnection::OnFound from daily builds
20010928 - 2001100805. 
N620 crashes look like internal testing, but all Trunk crashes are external users.

Windows stack:

nsLDAPConnection::OnFound
[d:\builds\seamonkey\mozilla\directory\xpcom\base\src\nsLDAPConnection.cpp, line
853] 
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 154] 
EventHandler [d:\builds\seamonkey\mozilla\xpcom\proxy\src\nsProxyEvent.cpp, line
515] 
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591] 
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524] 
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072] 
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 457] 
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1307] 
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1624] 
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1642] 
WinMainCRTStartup() 
KERNEL32.DLL + 0x192a6 (0x77e992a6) 

Linux stack:

nsLDAPConnection::OnFound() 
XPTC_InvokeByIndex() 
EventHandler() 
PL_HandleEvent() 
PL_ProcessEventsBeforeID() 
processQueue() 
nsVoidArray::EnumerateForwards() 
nsAppShell::ProcessBeforeID() 
handle_gdk_event() 
libgdk-1.2.so.0 + 0x1716b (0x4034516b) 
libglib-1.2.so.0 + 0x10055 (0x40375055) 
libglib-1.2.so.0 + 0x10659 (0x40375659) 
libglib-1.2.so.0 + 0x107e8 (0x403757e8) 
libgtk-1.2.so.0 + 0x9165b (0x4028a65b) 
nsAppShell::Run() 
nsAppShellService::Run() 
main1() 
main() 
libc.so.6 + 0x1c177 (0x404be177) 

Comments: 
   (36128168) Doing an LDAP lookup while composing Mail 
   (36179246) Doing an LDAP lookup while composing mail 
   (36186399) Typing an address in the addressing widget of the mail compose
window. 
   (36217481) writing an email  and it was searching an M$ LDAP database for the
name and Poof! it disappeared :-)
   (36318175) typing in compose autocomplete
   (36328621) autocompletechecked Local Address book+LDAP serverFound matches in
Local Address Book but hangs since LDAP server was unreachable
   (36407384) send link -> typed in adress  crashed while searching address
database.
(Reporter)

Comment 1

17 years ago
adding keywords for talkback.

dmose, will this be handled by 102270?
Keywords: crash, topcrash
(Assignee)

Comment 2

17 years ago
This was actually fixed in the trunk over the weekend and in the branch yesterday.

*** This bug has been marked as a duplicate of 102227 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Verified dup
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsLDAPConnection::OnFound]
You need to log in before you can comment on or make changes to this bug.