Checking credit balance on blau.de returns 'Session expired'

RESOLVED DUPLICATE of bug 1077392

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 1077392
4 years ago
4 years ago

People

(Reporter: sfoster, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8456195 [details]
blau-de-sesison-expired.png

In germany, using a blau.de SIM  (could apply to other networks/regions I'm not sure)

STR: 
 Dial the number to check credit balanace: *100#

Expected results: 
 Details of credit balance

Actual results: 
 'Session expired'
I'm also getting a lot of "Session expired" messages, even when checking the balance works.

Wonder if it could be a fallout from bug 1016885?
Flame:
> 07-14 10:14:31.207   348   418 D RILC    : [UNSL]< UNSOL_ON_USSD {0,Ihr Guthaben beträgt 9.48 EUR. SIM-Karte aktiv bis 16-07-2015. Günstige Tarifoptionen unter der kostenlosen Kurzwahl 1155.}
> 07-14 10:14:31.207   348   418 D RILC    : [UNSL]< UNSOL_ON_USSD {0,(null)}

Nexus S:
> 07-15 17:54:53.353    80   173 E RIL(s)  : RX: (M)IPC_SS_CMD  (S)IPC_SS_USSD  (T)IPC_CMD_NOTI (len:0x75 mseq:0xFF aseq:0x00) [ 01 0F 6B 49 B4 1C 74 AC D3 D1 61 71 D9 0D 12 97 E9 ... ]
> 07-15 17:54:53.361    80   173 E RIL(s)  : RX: (M)IPC_SS_CMD  (S)IPC_SS_USSD  (T)IPC_CMD_NOTI (len:0x0A mseq:0xFF aseq:0x00) [ 03 00 00 ]
> 07-15 17:55:01.248    80   173 E RIL(s)  : TX: (M)IPC_SS_CMD  (S)IPC_SS_USSD  (T)IPC_CMD_EXEC (len:0xC0 mseq:0xBB aseq:0x00) [ 03 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ... ]

Seems like we get a second empty/null USSD

Updated

4 years ago
See Also: → bug 1043817
I've figured out why this is happening and posted a fix in bug 1077392, duplicating against that one.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1077392
You need to log in before you can comment on or make changes to this bug.