Selecting the Mail & Newsgroup cat. and then selecting another cat. causes the OK button to become disabled.



MailNews Core
Simple MAPI
17 years ago
10 years ago


(Reporter: Trix Supremo, Assigned: Srilatha Moturi)


Windows 2000

Firefox Tracking Flags

(Not tracked)


(Whiteboard: [PDT+] [FIX on 094 branch])


(2 attachments)

5.07 KB, patch
: review+
(not reading, please use instead)
: superreview+
Details | Diff | Splinter Review
1.84 KB, text/html


17 years ago
If you select the Mail & Newsgroup category in the pref panel and then you
select any other category(like Advanced or Appearance), the OK button becomes
disabled which prevents your from saving your selections.

Comment 1

17 years ago
what build were you using Trix? I couldn't reproduce this on my machine using
the 20011009 .9.4 build.

Comment 2

17 years ago
This happens with today's build. Actually the OK button is not disable but if 
you click on OK the preferences dialog does not close.
To reproduce this problem you have to open Mail and Newsgroups preferences pane 
and then go to a different pane and click OK
Error: document.getElementById("mailnewsEnableMapi") has no properties
Source File: chrome://messenger/content/pref-mailnewsOverlay.js Line: 75

I am working on a fix right now.

Comment 3

17 years ago
Adding keyword nsbranch+
Keywords: nsbranch+

Comment 4

17 years ago
scott, thats the build i was able to verify it on: 20011009 .9.4. built this
morning.  Clicking on the Mail & Newsgroup cat. and click on any other cat.
causes the OK button to fail. was able to duplicate this on all builds actually.
back to the 20011001 test build of Mozilla.


17 years ago
Whiteboard: [PDT]

Comment 5

17 years ago
Created attachment 52803 [details] [diff] [review]
patch v1

Comment 6

17 years ago
looks good.


17 years ago
Attachment #52803 - Flags: review+


17 years ago
Priority: -- → P2
Comment on attachment 52803 [details] [diff] [review]
patch v1

Attachment #52803 - Flags: superreview+


17 years ago
QA Contact: trix → esther

Comment 8

17 years ago
tentantive PDT+, pending test plan and testing for regresions on prefs, in all
platforms. if all this done by 8 p.m., pls try and check this in to 094 branch.
Whiteboard: [PDT] → [PDT+]

Comment 9

17 years ago
Created attachment 53012 [details]
Testplan for testing SMAPI pref pane fix

Comment 10

17 years ago
Posted testplan for testing Srilatha's fix for this bug.  This testplan should
cover all of the basic functions and other regressions.  Testing will cover all
supported windows platforms. Testing status will be posted once available.

Comment 11

17 years ago
*** Bug 104130 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
Great - thanks, Trix.  cc'ing sairuh and scalkins as a fyi for their areas as
well to watch for this fix when it comes in to look at their areas in prefs.

Comment 13

17 years ago
Srilatha's fix on this test build has been validated on all windows supported
platforms: win98se, nt4.0, win2k, winXP, & winME.  testcases discussed in
attachment plus additional blackbox testing:(interactivity between Netscape Mail
and Browser, writing changed preferences to prefs.js, and verifying
functionality with radio buttons, checkboxes, textboxes, scrollbars, multilist
selectors, etc...)

Comment 14

17 years ago
Using Trix's Mozilla zip file on Windows NT 4.0:

I ran a quick regression/smoke test on most of the prefs by manually
selecting/changing few of the prefs in these main pref categories
and my favorite: Offline &Disk Space). Prefs were saved, enabled/disabled,
and worked as expected.

Tried using tab key to cycle through various prefs panels and no problem.

No obvious UI problems.

Tried seting a pref using the browser and then bringing up the pref
panel through composer/messenger and seeing if the prefs were saved
and no problems that I could see.

and tested the actual bug and I was able to Hit Ok button and the
prefs panel did close.

Comment 15

17 years ago
no obvious problems here either for me.  I say check it in tonight if you happen
to still be around.

Comment 16

17 years ago
Copied Yulian's test result here to support the check in tonight.

Subj:  Re: Build for testing simple Mapi preference bug # 103897 
Date:  10/10/2001 8:23:14 PM Pacific Daylight Time 
From: (Yulian Chang)
To: (Trix Supremo)
CC: (Srilatha Moturi), (Gary Chan), (Luke Gottlieb), (Scott MacGregor), 
tiantiankong8/ (Tiantian Kong),

It works well on my Windows 2000!



Comment 17

17 years ago
Checked into the 0.9.4 branch.

Comment 18

17 years ago
*** Bug 104285 has been marked as a duplicate of this bug. ***


17 years ago
Whiteboard: [PDT+] → [PDT+] [FIX on 094 branch]

Comment 19

17 years ago
Checked into 0.9.4 branch
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 20

17 years ago
Using winxp build 2001-10-15 and linux build 2001-10-16, MacosX 2001-10-15, and
Mac 9.1 build 2001-10-15 this is fixed.  I tested all of the Mail & Newsgroup
preference and then switched from the Mail/News preference to the Advanced
preference and changed the Cache preference.  All the OK's worked.

Comment 21

17 years ago
Note, my above verification was on branch builds.  Trix verified on trunk on 10-09.

Comment 22

17 years ago
My mistake, Trix didn't verify on Trunk, I misread his comment, so I will reopen
and put vtrunk in keyword.
Keywords: vtrunk
Resolution: FIXED → ---

Comment 23

17 years ago
Esther: we mark as fixed even though it's fixed in branch. 

Lisa suggested that we can query all simple MAPI bugs for trunk later on, and
that the vtrunk keyword is not necessary. 
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 24

17 years ago

Pls verify this one. Thx. 
QA Contact: esther → trix

Comment 25

16 years ago
verified on 2002022703 mozilla & netscape trunk builds
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.