Closed Bug 10391 Opened 21 years ago Closed 21 years ago

Unwanted jump to top of page

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P3)

PowerPC
Mac System 8.6
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: kimon, Assigned: joki)

References

()

Details

(Whiteboard: [TESTCASE] rhencke@tiac.net)

Attachments

(1 file)

Clicking anywhere in the window (not on a link) should do nothing. Instead, at least while at mozillazine.org a click will make the browser scroll all the way to the top of the page and then the user has to manually re-scroll back to where he was.
Assignee: don → joki
Component: Browser-General → Event Handling
QA Contact: leger → janc
janc can you reproduce?  seen on all platforms?  Known bug?
Whiteboard: [MAKINGTESTCASE] rhencke@tiac.net
This bug is reproducible using Win32 build ID 1999071417 (Milestone 8) running
on Windows 98.  So the bug appears to be crossplatform..
This bug does not occur in Netscape Navigator v4.x (tested on v4.08)

This problem can be viewed at: http://www.mozillazine.org

The problem appears to be clicking underneath the side menu causes the browser
to scroll up to near the top of the page.

How to reproduce:
 1) Go to www.mozillazine.org
 2) Scroll down the page a little bit (middle of the page is plenty)
 3) Click anywhere under the mozillaZine side menu (the one containing
submitArticle, chromeZone, etc..)
    The click must occur outside the green border of the side menu. (to the
left/right, or underneath)

What happens:
 Clicking outside the sidebar box makes the browser window scrolls back up to
near the top of the page.
 Clicking within the sidebar box does NOT cause the browser window to scroll
back up.
Whiteboard: [MAKINGTESTCASE] rhencke@tiac.net → [TESTCASE] rhencke@tiac.net
For the test case to work, the window must be small enough vertically so it is
possible to scroll up and down the table.
*** Bug 11937 has been marked as a duplicate of this bug. ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
This seems to be fixed.  The problem was probably with selection codes attempt
to find the nearest text misbehaving.
Keywords: verifyme
Verified.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.