All users were logged out of Bugzilla on October 13th, 2018

[Dialer][Call Screen] It's not possible to start a second call

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: oteo, Assigned: drs)

Tracking

unspecified
2.1 S1 (1aug)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected)

Details

(Whiteboard: [planned-sprint])

(Reporter)

Description

4 years ago
Tested in latest master build

STR:
1.Open Dialer application
2.Establish a call
3.Try to initiate a second call to a contact in the Agenda, tapping "Add Contact" button in the call screen.

Expected Result: Contact list is showed so user can call to a contact in the agenda

Current Result: Black screen appears instead

Environment info
-----------------
master, hamachi
B-229
Gecko-0558157
Gaia-122bb7
(Reporter)

Comment 1

4 years ago
I've just checked that the issue is not happening in 2.0 latest build

Environment info
-----------------
v2.0, hamachi
B-40
Gecko-5b0fd39
Gaia-db0358b
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.1?
Summary: It's not possible to start a second call → [Dialer][Call Screen] It's not possible to start a second call
Hi Mari Ángeles! I have just try it with today's build (Gecko-8715ca5.Gaia-933165a) and applying current master (as for now) on top and the issue seems to be solved :) Would you be so kind to re-test it, please? Thanks!
Flags: needinfo?(oteo)
Oh boy! There it is again in master so, as I thought it could be, it seems to be some kind of race condition related to the handling of the 'dial' Web activity... :) #badnews
Flags: needinfo?(oteo)
Aaand I think at least I found the way to get over it since it was blocking a couple of patches I had :)

To overcome it I just:

make install-gaia or make reset-gaia (from master)

and

APP=communications make install-gaia

It seems that it solves the issue if this is blocking you ;) After rebooting the issues reproduces again and you'll have to execute |APP=communications make install-gaia| again.
(Assignee)

Updated

4 years ago
Assignee: nobody → drs+bugzilla
(Assignee)

Updated

4 years ago
Target Milestone: --- → 2.1 S1 (1aug)
(Assignee)

Updated

4 years ago
Whiteboard: [planned-sprint]
(Assignee)

Comment 5

4 years ago
I can't repro this on my Flame. Does this only occur on the Hamachi/Buri?
Keywords: qawanted
Hi guys, I have heavily tested the establishment of second calls for the testing of some other bugs I have been working on and as far as my testing this bug can be considered as solved :) So, setting it as WORKSFORME.

BTW, I tested it on the Hamachi using Gecko-692e97f.Gaia-19e9536 and since Doug has tested in on the Flame I guess we are pretty sure on this one ;) Thanks everyone!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 7

4 years ago
Thanks, Germán.
Keywords: qawanted

Updated

4 years ago
blocking-b2g: 2.1? → ---
You need to log in before you can comment on or make changes to this bug.