Closed Bug 1039582 Opened 6 years ago Closed 6 years ago

Investigate disabling parallel tests in content/media/test

Categories

(Core :: Audio/Video, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1036992

People

(Reporter: sydpolk, Unassigned)

References

Details

Attachments

(2 files)

Currently, test_seek.html is highly intermittent, so much so that it has been disabled for b2g. (see https://bugzilla.mozilla.org/show_bug.cgi?id=981153). This investigation will enable it for b2g and Android, but not run tests in parallel. On my MacBook Pro, running with PARALLEL_TESTS = 2 takes 11 minutes; with PARALLEL_TESTS = 1 takes 17 minutes.
Got syd's patch in email. Pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=939398bcc18f

Also, Syd, you need to configure your editors to use linux only line endings.

Please attach your patches here.
Attached patch 1039582.patchSplinter Review
Flags: needinfo?(ctalbert)
Please refer to [1]. We should set PARALLEL_TESTS to 1 only in test_seek.html when it is B2G or Android in order not to slow down tests on other platforms.

[1] http://hg.mozilla.org/mozilla-central/file/4024d8019701/content/media/test/manifest.js#l258
jwwang: Your point is certainly well-taken. Right now we are doing investigation. If indeed we decide to proceed in this direction, we will be doing what you suggest. Thanks!
Blocks: 1022453
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1036992
This patch caused too many failures as many tests depend on PARALLEL_TESTS being > 1. Investigation subsumed by 1036992.
You need to log in before you can comment on or make changes to this bug.