Closed Bug 1039677 Opened 7 years ago Closed 7 years ago

use content iterator for accessible tree traversal

Categories

(Core :: Disability Access APIs, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1016545

People

(Reporter: surkov, Assigned: surkov)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached patch patchSplinter Review
that allows us to not put the whole DOM tree into number of arrays. 

Olli, do you see ways how it can be improved?
Attachment #8457067 - Flags: feedback?(bugs)
(In reply to alexander :surkov from comment #0)
> Created attachment 8457067 [details] [diff] [review]
> patch
> 
> that allows us to not put the whole DOM tree into number of arrays. 
> 
> Olli, do you see ways how it can be improved?

turns out bug  1016545 is caused by snow white keeping content lists alive longer than they need to be and so piling up, so I have a patch I like better that I'll post there.
Attachment #8457067 - Flags: feedback?(bugs)
ok, I don't mind, marking it as dupe of bug 1016545 then
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1016545
You need to log in before you can comment on or make changes to this bug.