If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Source server doesn't work for header files from objdirs

RESOLVED DUPLICATE of bug 462159

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 462159
3 years ago
3 years ago

People

(Reporter: dmajor, Unassigned)

Tracking

33 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
In most crash dumps the top frame is likely to pop up an error like:

The file 'https://hg.mozilla.org/mozilla-central/raw-file/1f65008ee272/obj-firefox/dist/include/js/HashTable.h' cannot be opened

That's because the compiler gets headers from the objdir, but their permanent home is elsewhere in the tree. I *think* we can do some PDB remapping here: 
http://dxr.mozilla.org/mozilla-central/source/toolkit/crashreporter/tools/symbolstore.py#613

That currently produces data like this:
c:\builds\moz2_slave\m-cen-w32-ntly-000000000000000\build\obj-firefox\dist\include\js\HashTable.h*obj-firefox/dist/include/js/HashTable.h*1f65008ee272

...which gets split by '*' delimiter and fed into this expression:
HTTP_EXTRACT_TARGET=%hgserver%/raw-file/%var3%/%var2%

So we would need to fix up the var2 piece. It would require knowledge of where each header file actually comes from. I don't know whether that knowledge already exists or is feasible to create.
This has been around forever, sadly. I think it's more plausible to fix nowadays.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 462159
You need to log in before you can comment on or make changes to this bug.