bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

API usage error in ceph _fetch_from_boto_s3()

RESOLVED FIXED in 95

Status

Socorro
Backend
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: rhelmer, Assigned: rhelmer)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

4 years ago
Traceback (most recent call last):
  File "/data/socorro/application/socorro/processor/processor_app.py", line 127, in transform
    dumps = self.source.get_raw_dumps_as_files(crash_id)
  File "/data/socorro/application/socorro/external/ceph/crashstorage.py", line 237, in get_raw_dumps_as_files
    return self.transaction(self.do_get_raw_dumps_as_files, crash_id)
  File "/data/socorro/application/socorro/database/transaction_executor.py", line 104, in __call__
    result = function(connection, *args, **kwargs)
  File "/data/socorro/application/socorro/external/ceph/crashstorage.py", line 215, in do_get_raw_dumps_as_files
    dumps_mapping = boto_s3_store.get_raw_dumps(crash_id)
  File "/data/socorro/application/socorro/external/ceph/crashstorage.py", line 204, in get_raw_dumps
    return self.transaction(self.do_get_raw_dumps, crash_id)
  File "/data/socorro/application/socorro/database/transaction_executor.py", line 104, in __call__
    result = function(connection, *args, **kwargs)
  File "/data/socorro/application/socorro/external/ceph/crashstorage.py", line 194, in do_get_raw_dumps
    dump_name
  File "/data/socorro/application/socorro/external/ceph/crashstorage.py", line 336, in _fetch_from_boto_s3
    thing_as_string = key.get_contents_as_string()
AttributeError: 'NoneType' object has no attribute 'get_contents_as_string'
(Assignee)

Updated

4 years ago
Blocks: 1008246
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1039781

Comment 2

4 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/32447a5a45ec44d6e6ae067f13b3a1d35699f0ff
Merge pull request #2218 from twobraids/none-ceph

Fixes Bug 1040249 - Api usage error

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Target Milestone: --- → 95
You need to log in before you can comment on or make changes to this bug.