"KeyError during shutdown" has returned

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
8 months ago

People

(Reporter: rfkelly, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa+])

(Reporter)

Description

5 years ago
Per Bug 1040396 Comment 6:

"""
Related to that:
/media/ephemeral0/logs/tokenserver/token.error.log
Exception KeyError: KeyError(22260464,) in <module 'threading' from '/usr/lib64/python2.6/threading.pyc'> ignored

So, the Key Error shows up in the hekad logs and the token error logs...
"""

This is a janky python thing caused by some bad module shutdown ordering.  I thought we had a fix in place for it but it seems to be back.  Not a high priority but it would be good not to crowd the logs.
Whiteboard: [qa+]
(Reporter)

Comment 1

5 years ago
Apparently this is a known bad interaction with gevent, caused by incorrect import order:

  http://stackoverflow.com/questions/8774958/keyerror-in-module-threading-after-a-successful-py-test-run

We should put some hooks in place to detect it and error out early rather than getting into this state that gives errors on shutdown.
(Reporter)

Updated

8 months ago
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.