Closed Bug 1040592 Opened 7 years ago Closed 7 years ago

Memory leakage related to deadlock detector

Categories

(Core :: XPCOM, defect)

All
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1027921

People

(Reporter: swu, Unassigned)

Details

(Whiteboard: [MemShrink])

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #1039914 +++

When doing the interations of array buffer transfer in mochitest of bug 1037358, the "heap-unclassified" in about:memory keeps increasing, it indicates a potential memory leakage.

In the DMD log, there are many unreported heap records related to mozilla::dom::workers::WorkerPrivate::CreateNewSyncLoop().
Attached file DMD report
Attached is the DMD report.
Attached is the test to reproduce.
So this memory is being used in the deadlock detector.  You can see some other things consuming far more than workers, like the cache.  Every time we create a Mutex we put an entry in some hashtable.  It's not clear to me that we ever remove those ...
Component: DOM: Workers → XPCOM
Summary: Memory leakage related to mozilla::dom::workers::WorkerPrivate::CreateNewSyncLoop() → Memory leakage related to deadlock detector
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #4)
> So this memory is being used in the deadlock detector.  You can see some
> other things consuming far more than workers, like the cache.  Every time we
> create a Mutex we put an entry in some hashtable.  It's not clear to me that
> we ever remove those ...

Eric had (re)discovered this and was grousing about it at some point...
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1027921
No longer blocks: 1039914
(In reply to Eric Rahm [:erahm] from comment #6)
> See bug 1027921.

Thanks for this info.
You need to log in before you can comment on or make changes to this bug.