Closed Bug 1040597 Opened 9 years ago Closed 8 years ago

[Dolphin][Dialer]End a phone call, sometimes has a black screen flicker

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:-, b2g-v1.4 affected, b2g-master fixed)

RESOLVED FIXED
blocking-b2g -
Tracking Status
b2g-v1.4 --- affected
b2g-master --- fixed

People

(Reporter: mlien, Unassigned)

References

Details

(Whiteboard: [1.4-dolphin-test-run-2])

[Device]
  Dolphin
---------------------------------------------
[Reproduction build] - 0710pac + pvt gaia+gecko
  Gaia      e0a732cf172d125eadfad59f0faf8f73b62012b8
  Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/074223c547af
  BuildID   20140717160202
  Version   30.0
  ro.build.version.incremental=282
  ro.build.date=Thu Jul 10 10:27:07 CST 2014

---------------------------------------------
[Reproduce Steps]
  1. Launch Dialer app
  2. Make a phone call -> End the phone call after 3~5 seconds
---------------------------------------------
[Expected Result]
  Screen back to dialer page directly
---------------------------------------------
[Actual Result]
  Sometimes time has a black screen flicker
  Both Flame v1.4 and v2.1 are fine

---------------------------------------------
[Reproduce Rate]
  90%
Due to typo, update result again

[Actual Result]
  Sometimes there has a black screen flicker
  Both Flame v1.4 and v2.1 are fine
Hi Mike,

Please check if this issue happens on Buri. It looks the performance issue and need data on buri.
Flags: needinfo?(mlien)
verify with Buri v1.4 and it's fine

Gaia      621d152f89347c79619aa909ad62cc2ac9d3ab5b
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/74bc2539e3df
BuildID   20140721160202
Version   30.0
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013
Flags: needinfo?(mlien)
Hi James, Could you please kindly find someone check this first ??
Thanks!!
Flags: needinfo?(james.zhang)
Arvin and Siiaceon, can you check this issue?
Flags: needinfo?(siiaceon.cao)
Flags: needinfo?(james.zhang)
Flags: needinfo?(arvin.zhang)
Sorry to reply late.

I've checked the issue and preliminary analysis result is:

1) Recently, We had landed the patch of bug1006274 into v1.4 locally so that dolphin(sprd version) almost exists the issue with a hundred percent.

2) However, the issue still can be reproduced easily after we remove the patch especially on the case MOC. I also checked on another case:
  a) keep settings app foreground and make a MTC;
  b) hang up the call on remote device after phone rang for a while;
  c) there'll a white screen flicker before settings app shown(In flame1.4, there will be a slightly halt of settings app).
Another point we need attention especially is that there's always shown the background of homescreen shortly after callscreen disappeared.

In my opinion, this might be the performance problem of application switching --- callscreen and dialer/settings/etc. But I do think we'd better ask someone else help confirm it and propose some more beneficial suggestions.

Hi Etienne, would you please do me a favor, thanks a lot.
Flags: needinfo?(siiaceon.cao)
Flags: needinfo?(etienne)
Flags: needinfo?(arvin.zhang)
From descriptions and comments this looks like a minor UX glitch, 1.4- for now.

Etienne, if you do have time to check this and feel the need to nominate it please feel free to do so.
blocking-b2g: 1.4? → -
Sorry, I was too late on this one :)
And I think the only way to fix this 100% is what we did with the AttentionWindows (2.1, bug 927862) because the system needs to know about the callscreen transition (it's not the case in 1.4).
Flags: needinfo?(etienne)
Status: NEW → RESOLVED
Closed: 8 years ago
Depends on: attention-window
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.