Closed Bug 1040769 Opened 5 years ago Closed 3 years ago

Intermittent test_bug570341.html | Expected (navigationStart|domLoading|domInteractive) to happen before (unloadEventStart|domInteractive|domComplete)

Categories

(Core :: DOM: Core & HTML, defect, P3)

x86
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox51 --- wontfix
firefox52 --- fixed
firefox53 --- fixed

People

(Reporter: cbook, Assigned: gbrown)

References

()

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Ubuntu VM 12.04 x64 mozilla-inbound pgo test mochitest-e10s-2 on 2014-07-18 06:05:21 PDT for push d2c2032ea5ab

slave: tst-linux64-spot-043

https://tbpl.mozilla.org/php/getParsedLog.php?id=44107030&tree=Mozilla-Inbound

517 INFO TEST-UNEXPECTED-FAIL | /tests/docshell/test/test_bug570341.html | Expected navigationStart to happen before unloadEventStart, got navigationStart = 1405688955403, unloadEventStart = 0
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
Android Debug only (currently), like bug 1059266 and bug 1069295 (likely dups).
Assignee: nobody → gbrown
Keywords: leave-open
Summary: Intermittent test_bug570341.html | Expected navigationStart to happen before unloadEventStart, got navigationStart = 1405688955403, unloadEventStart = 0 → Intermittent test_bug570341.html | Expected (navigationStart|domLoading|domInteractive) to happen before (unloadEventStart|domInteractive|domComplete)
Whiteboard: [test disabled on Android debug]
Duplicate of this bug: 1059266
Duplicate of this bug: 1069295
Pushed by philringnalda@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6592d8792c02
disable test_bug570341.html on Android debug for constant failures
One of the conditions that can end the test is:

                      Date.now() >= start + 5000;

which I read as, "if the test hasn't succeeded after 5 seconds, bail out so that a better error message is generated than 'timeout'". It is useful, but dangerous on slow platforms like Android Debug. Increasing this interval eliminates at least 90% of the failures.

Another condition is:

                      (seenLoad && Date.now() >= seenLoad + 200) 

which I read as "we expect valid data shortly after load". That doesn't seem to cause frequent failures, but 200 ms seems too short for Android, so I've increased that also.

Those changes seem effective: https://treeherder.mozilla.org/#/jobs?repo=try&revision=9dca700425050bb69f8885fb5e31c305b9b73ec5
Attachment #8813299 - Flags: review?(overholt)
Attachment #8813299 - Flags: review?(overholt) → review?(ehsan)
Comment on attachment 8813299 [details] [diff] [review]
increase poll timeouts and enable test

Review of attachment 8813299 [details] [diff] [review]:
-----------------------------------------------------------------

::: docshell/test/test_bug570341.html
@@ +109,5 @@
>    frames[0].location = 'bug570341_recordevents.html'
>    var interval = setInterval(function () {
>      var stopPolling = (win.performance && win.performance.loadEventEnd) ||
> +                      (seenLoad && Date.now() >= seenLoad + 3000) ||
> +                      Date.now() >= start + 30000;

Please add a comment here saying that these are arbitrary numbers picked to satisfy the test gods and should the said gods decide so we shall bring them more sacrificial milliseconds.

r=me with that.  :-)
Attachment #8813299 - Flags: review?(ehsan) → review+
Keywords: leave-open
Whiteboard: [test disabled on Android debug]
https://hg.mozilla.org/mozilla-central/rev/8ff60c9990cc
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.