Closed Bug 1040966 Opened 6 years ago Closed 6 years ago

framework failures running tests on unusual chars in the output

Categories

(Firefox Build System :: General, defect)

x86_64
Linux
defect
Not set

Tracking

(firefox33 fixed, firefox34 fixed)

RESOLVED FIXED
mozilla34
Tracking Status
firefox33 --- fixed
firefox34 --- fixed

People

(Reporter: jesup, Assigned: ted)

References

Details

Attachments

(2 files)

Attached file bar
I just merged forward (since yesterday?) and running a test for leaks I see this: UnicodeEncodeError: 'ascii' codec can't encode character u'\ufffd' in position 107: ordinal not in range(128)

Doing ./mach test  content/media/test/test_fake_h264.html

Testing bug 1037125 plus bug 1040345 (in the middle of trying to merge the changes and run the tests).

Note: even disabling the fixes code I'm seeing problems.
If I print the message it looks like:
520455936[7fd60c18b4a0]: [GSM Task|tnp] ui.c:654: SIPCC-UI_API: 1/2, ui_set_call_status: the stat string =�

...so I think some logging code is spewing out bad strings, but we should sanitize them instead of choking.
Blocks: 886570
This is sort of terrible but it works around the issue.
Attachment #8460428 - Flags: review?(ahalberstadt)
Assignee: nobody → ted
Status: NEW → ASSIGNED
Comment on attachment 8460428 [details] [diff] [review]
Fix unicode encoding when passing bad unicode to stack fixer

Review of attachment 8460428 [details] [diff] [review]:
-----------------------------------------------------------------

Yuck, if it works though then good enough for me.
Attachment #8460428 - Flags: review?(ahalberstadt) → review+
Comment on attachment 8460428 [details] [diff] [review]
Fix unicode encoding when passing bad unicode to stack fixer

Review of attachment 8460428 [details] [diff] [review]:
-----------------------------------------------------------------

::: testing/mochitest/runtests.py
@@ +1917,5 @@
>        return message
>  
>      def fix_stack(self, message):
>        if message['action'] == 'log' and self.stackFixerFunction:
> +        message['message'] = self.stackFixerFunction(message['message'].encode('ascii', 'replace'))

y u no utf-8?
That just kicks the can down the road and we hit an error later. We can leave this open and fix it right, but this unbreaks developers right now.
Duplicate of this bug: 1041358
https://hg.mozilla.org/mozilla-central/rev/305e0ca907a8
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.