search double escapes for netscape search

VERIFIED FIXED

Status

VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: matt, Assigned: matt)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

17 years ago
search 2.0 does not require UTF-8 to be passed into the query string.  Right now
we are doing this with the netscape sherlock file.  Thus we esccape % to be %25
and it shows up in the search form.

Need to take out UTF-8 as input from sherlock file.
(Assignee)

Comment 1

17 years ago
Created attachment 52982 [details] [diff] [review]
sherlock diff
(Assignee)

Comment 2

17 years ago
need reviews.
Pointing to new psp server and also taking input.

Comment 3

17 years ago
Comment on attachment 52982 [details] [diff] [review]
sherlock diff

r=sgehani.
Attachment #52982 - Flags: review+

Comment 4

17 years ago
Can we get a review/consultation from a netscape.com search engineer?  Todd,
know of any?

Is this going to go in for 0.9.6?

Comment 5

17 years ago
Myron, is this something that Shawkat could look at?

Comment 6

17 years ago
Created attachment 53423 [details]
Updated NSCP sherlock file w/o support for UTF-8

Comment 7

17 years ago
I've removed support for UTF-8 in the Netscape Sherlock file and attached it to
this bug report. Please test it and if it flies, put it into the next build and
in the sherlock director on the server at:

http://search.netscape.com/sherlock/SBWeb_01.src

(Assignee)

Comment 8

17 years ago
To things about that file:
At the bottom the 
updateCheckDays = 1

should be 

updateCheckDays = "1"

and for some reason the the formating is off at the bottom on the file.  Lot's 
of spaces but that won't affect anything.  Also this attachment should be in 
bugscape since it should be in the netscape comm. builds.  I believe I have a 
bug filed with these changes in it.  I'm behind the firewall so I don't know 
the bug number.

Comment 9

17 years ago
Comment on attachment 52982 [details] [diff] [review]
sherlock diff

sr=blake
Attachment #52982 - Flags: superreview+
(Assignee)

Comment 10

17 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.