Unable to connect with local proxy unless "Use this proxy server for all protocols" is checked.

RESOLVED DUPLICATE of bug 1041511

Status

()

RESOLVED DUPLICATE of bug 1041511
4 years ago
4 years ago

People

(Reporter: marty6001, Unassigned)

Tracking

33 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140717132905

Steps to reproduce:

When setup with Manual Proxy Configuration: HTTP proxy localhost 8080 only the page will not connect when attempting to navigate from any bookmark on the Menu Bar. Inputting web addresses into the URL bar does not have the problem. The only solution is to check "Use this proxy server for all protocols". That however forces users to configure the proxy with all protocols, which is undesirable.
(Reporter)

Comment 1

4 years ago
May be related to bug 354493
Thanks for filing the bug Marty! Please see bug 1041511 - I have a patch there that might work for you. There are also links to builds that you can try in bug 1041511 comment 2.
Pretty confident that this is the same thing as bug 1041511. Duping to that one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1041511
(Reporter)

Comment 4

4 years ago
(In reply to Steve Workman [:sworkman] from comment #2)
> Thanks for filing the bug Marty! Please see bug 1041511 - I have a patch
> there that might work for you. There are also links to builds that you can
> try in bug 1041511 comment 2.

Tried this build from here:

http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/sworkman@mozilla.com-fbcf5e00bde0/try-win32/

Everything appears normal again with it, at least the localhost problem is cleared up.
Awesome Marty! Thanks for testing! You can follow the progress of the patch in bug 1041511.
You need to log in before you can comment on or make changes to this bug.