Closed Bug 1041585 Opened 5 years ago Closed 5 years ago

incorrect "server not found" error after editing url

Categories

(Firefox :: Untriaged, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1041511

People

(Reporter: glob, Unassigned)

References

Details

when editing a url to change the hostname part to just the name of a server on my lan firefox display the "server not found" error page.  .

steps:

1. load https://bugzilla.mozilla.org/buglist.cgi?f1=content&list_id=10786385&o1=isnotempty&chfieldto=Now&query_format=advanced&chfieldfrom=-3m

2. edit the url, change https://bugzilla.mozilla.org to bz
the address displayed is:
> bz/buglist.cgi?f1=content&o1=isnotempty&chfieldto=Now&query_format=advanced&chfieldfrom=-3m&list_id=10787084

3. press return

expected:

- the page should load

actual:

- "server not found" error

notes:
- if i copy the exact same url and paste it into a new tab, the page is loaded correctly
- prepending http:// to the url doesn't resolve the issue
are you sure that's bug 693808 and not bug 354493, unfortunately they landed same day and both change local hosts behavior :(
since you visited a local host from a remote host, I'm prone to say it's bug 354493, and very likely a duplicate of bug 1041511 (or at least solved by the same patch)
(In reply to Marco Bonardo [:mak] from comment #2)
> since you visited a local host from a remote host, I'm prone to say it's bug
> 354493, and very likely a duplicate of bug 1041511 (or at least solved by
> the same patch)

Indeed. Glob, can you check?
Flags: needinfo?(glob)
[some time passes as i set up a firebox build environment]

yes, the patch on bug 1041511 fixes this issue.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(glob)
Resolution: --- → DUPLICATE
Duplicate of bug: 1041511
You need to log in before you can comment on or make changes to this bug.