"Host not found" dialog acts modal!

VERIFIED DUPLICATE of bug 74331

Status

()

defect
VERIFIED DUPLICATE of bug 74331
18 years ago
15 years ago

People

(Reporter: hniksic, Assigned: asa)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
It has come as quite a surprise to discover that the "host not found" dialog box
acts as a modal dialog, i.e. it disallows further action until you click "OK". 
This is a big problem because failure to resolve a host in one Mozilla window
effectively paralyses all the other browser windows.

To repeat: open two mozilla windows.  Open google in one of them and 
http://nosuchdomain.com/ in the other.  After some time, you will get the dialog
box saying that "nosuchdomain.com" was not found.  When that happens, try
conducting a google search or following a link before clicking the "OK" button
on the dialog.

This bug is especially nasty in window manager settings where the dialog window
is automatically placed in the same workplace with the "offending" browser
window.  In that case, the user may witness Mozilla go catatonic without a
discernable cause.  Only after finding the appropriate dialog and clicking "OK"
can the user continue the work.

Besides the inconvenience factor, I'm not sure what kind of policy Mozilla
implements on modal dialogs.  Most Mozilla dialogs under X do not appear to be
modal, including Preferences.  Unless there are technical reasons I am not aware
of, I believe there is no good reason for "host not found" dialog to be modal.
Reporter:
Thanks for this bug report !
But please add in the future in all bug reports the build ID.

*** This bug has been marked as a duplicate of 74331 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Status: RESOLVED → VERIFIED
Component: Browser-General → Networking: HTTP
You need to log in before you can comment on or make changes to this bug.