Firefox update hotfix possibly incompatible with Firefox Portable

REOPENED
Unassigned

Status

()

Firefox
General
REOPENED
4 years ago
2 years ago

People

(Reporter: lagu, Unassigned)

Tracking

(Blocks: 1 bug)

30 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

I'm using Firefox 30 as portable Version from http://portableapps.com/de/apps/internet/firefox_portable.

The hotfix got installed, but firefox was version 30 befor the hotfix firefox got installed

I saved the profil to recheck if needed.
(Reporter)

Updated

4 years ago
Blocks: 1040228
(Reporter)

Comment 1

4 years ago
Created attachment 8460274 [details]
Firefox_Hotfix_30.png

Updated

4 years ago
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
(Reporter)

Comment 2

4 years ago
My portable firefox now tries every start to update.
But it seems that he isn't able to finish.

Firefox doesn't restart after he thinks that the update is sucessfull, becouse he thinks that an other firefox is still running.
(Reporter)

Comment 3

4 years ago
(In reply to Lars Gusowski [:lagu] from comment #2)
> My portable firefox now tries every start to update.
> But it seems that he isn't able to finish.
> 
> Firefox doesn't restart after he thinks that the update is sucessfull,
> becouse he thinks that an other firefox is still running.

i need to correct. The error said, that the update wasn't sucessfull.
i added the error_msg (in german - as my profil is in german)
(Reporter)

Comment 4

4 years ago
Created attachment 8460289 [details]
Firefox_error.png

Comment 5

4 years ago
The hotfix *always* gets installed. The question is why it didn't recognize that it is incompatible with your Firefox 30 installer.

I'm looking into this now.
Assignee: nobody → gps
Status: NEW → ASSIGNED

Comment 6

4 years ago
I am unable to reproduce this.

First, if you install Portable Firefox, it has app.update.auto=false and triggering a background update check will *not* install hotfixes.

If I change that pref to true and trigger a background update check, the update hotfix installs. However, the hotfix (correctly) determines that it isn't applicable because the current version of Firefox is new enough (Firefox 30) and the hotfix uninstalls itself.

Here's what I think is happening.

Your app.update.auto pref in PortableFirefox got flipped to true. When I did this, Firefox successfully downloaded and applied a Firefox update *from Mozilla*. That appeared to work. However, I suspect in your case that download is somehow conflicting with PortableFirefox.

PortableFirefox is likely disabling app.update.auto because it conflicts with them. Yet, they still allow that pref to be changed and for a Mozilla-supplied update to be installed. That feels wrong to me.

At this point, I'm inclined to blame this on a) PortableFirefox providing a footgun that allows installs to be upgraded to a "not PF" version b) you inadvertently triggering that. I think PF is in the wrong here, not the update hotfix.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
The copy of Firefox within Firefox Portable is a completely unaltered copy of Firefox.  No changes are made to it.  The Firefox updater is supposed to work with a portable Firefox since it is just a normal copy of Firefox launched with a -profile switch on the command line.  The updater was set to not upgrade automatically, but to notify the user of an update, years ago with Mozilla's permission because updates can take much longer on a USB drive.  We prefer users to use the PortableApps.com Platform to update so that both the Firefox components and FirefoxPortable components (the launcher that adjusts Firefox profile paths and cleans up all the empty directories and registry entries it leaves behind on the local PC) get update.  But we have hundreds of thousands of users that use the Firefox updater with Firefox Portable and have since the Firefox updater originally debuted.

Source: I created the first release of 'Portable Firefox' back in 2004 and continue to maintain it as part of PortableApps.com today.

Comment 8

4 years ago
Firefox updater is one thing. The hotfix downloads and runs a full installer, not an updater. I wonder if this difference isn't playing nicely with PF.

Is there any way we could detect PF? If so, I'd be inclined to exclude it from the hotfix if/when it is re-released. Reopen this bug if you think that makes sense and there's a way to detect PF.
You can't detect whether a given copy of FF is within Firefox Portable or not because its just Firefox.  That's by design.  It's quite literally just Firefox.exe run with a -profile switch in terms of how it behaves while its running.  The Firefox updater has worked perfectly fine through its entire existence within that sort of environment (not 'installed' in the registry and run with -profile).

Is there something new and different about these 'hotfixes'?  Do they not play well with Firefox.exe launched with -profile?

We should probably get this sorted as there are still millions of users running Firefox Portable and a not-insignificant portion only update via Firefox's built-in updater.
The hotfix downloads and runs a full installer .exe as opposed to an updater. It's the same as downloading and running something from https://www.mozilla.org/en-US/firefox/all/. That could theoretically lead to badness with Firefox Portable. I've only seen this one bug report. I'm inclined to believe Lars was a one-off.
(Reporter)

Comment 11

4 years ago
Is there any possibility to delete the files downloaded due the hotfix?
Then i could delete them, becouse the installation process during the startup is worse.
then i could wrote an cmd or batchfile wich delete it everytime befor starting firefox portable as workaround.

To the point that i am the only one:
I could offer you my profile to check if the profil is corrupted.

About the number and the behavior from the portable user could tell john more.
I imagine most people could live with the error or change the browser befor they would create an bugreport.

And if that is the way, we would lose some Firefox Portable Users.

Is there a possibility to check where the firefox.exe is?
if they is located in an %\app\Firefox folder and there exist %\Data\settings\FirefoxPortableSettings.ini i imagine it could be traced as firefox portable.

Or could the location of the Settings.ini be changed due the user @ John
Status: RESOLVED → REOPENED
Flags: needinfo?(bugzilla)
Resolution: WORKSFORME → ---
I was unable to reproduce the installation error reported by Lars.

Unless we hear more reports that the hotfix is causing harm to Firefox Portable users, I'm inclined to sit on our hands until the next planned hotfix re-release (no clue when that will be).

If there is a FirefoxPortableSettings.ini, we will check for that and add an exclusion to the hotfix if it is proven that the hotfix is causing harm with Firefox Portable.

Lars: Once the hotfix runs, the damage is done. The way you recover is reinstalling Firefox Portable (and copying your profile?).

Updated

4 years ago
Summary: Firefox Hotfix 20140527.01.3 got installed in firefox 30 → Firefox update hotfix possibly incompatible with Firefox Portable

Updated

4 years ago
Assignee: gps → nobody
Please close this bug as it is no longer relevant.
Flags: needinfo?(bugzilla)
You need to log in before you can comment on or make changes to this bug.