A few unused function parameters

VERIFIED DUPLICATE of bug 999715

Status

VERIFIED DUPLICATE of bug 999715
5 years ago
4 years ago

People

(Reporter: pdehaan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa+])

(Reporter)

Description

5 years ago
Steps to reproduce:
1. Edit .jslintrc and set "unused" to true.
2. Run `make lint`.


Actual results:
```
$ make lint
test/functional_test.js: line 413, col 28, 'res' is defined but never used.
test/functional_test.js: line 498, col 40, 'res' is defined but never used.
test/functional_test.js: line 562, col 42, 'res' is defined but never used.
test/functional_test.js: line 580, col 44, 'res' is defined but never used.
test/functional_test.js: line 675, col 28, 'res' is defined but never used.
test/functional_test.js: line 730, col 41, 'res' is defined but never used.
test/functional_test.js: line 1041, col 32, 'res' is defined but never used.
test/functional_test.js: line 1041, col 27, 'err' is defined but never used.
test/functional_test.js: line 1052, col 32, 'res' is defined but never used.
test/functional_test.js: line 1052, col 27, 'err' is defined but never used.
test/functional_test.js: line 1183, col 36, 'res' is defined but never used.
test/functional_test.js: line 1183, col 31, 'err' is defined but never used.
test/functional_test.js: line 1209, col 36, 'res' is defined but never used.
test/functional_test.js: line 1209, col 31, 'err' is defined but never used.
test/functional_test.js: line 1270, col 36, 'res' is defined but never used.
test/functional_test.js: line 1270, col 31, 'err' is defined but never used.

test/fxa_test.js: line 76, col 28, 'res' is defined but never used.
test/fxa_test.js: line 105, col 58, 'assertion' is defined but never used.
test/fxa_test.js: line 125, col 23, 'data' is defined but never used.
test/fxa_test.js: line 135, col 23, 'data' is defined but never used.
test/fxa_test.js: line 147, col 23, 'data' is defined but never used.

test/index_test.js: line 383, col 32, 'res' is defined but never used.
test/index_test.js: line 383, col 27, 'err' is defined but never used.

test/middlewares_test.js: line 57, col 26, 'res' is defined but never used.
test/middlewares_test.js: line 57, col 21, 'err' is defined but never used.

test/storage_test.js: line 122, col 73, 'err' is defined but never used.
test/storage_test.js: line 124, col 24, 'err' is defined but never used.
test/storage_test.js: line 136, col 73, 'err' is defined but never used.
test/storage_test.js: line 138, col 24, 'err' is defined but never used.
test/storage_test.js: line 149, col 73, 'err' is defined but never used.
test/storage_test.js: line 151, col 24, 'err' is defined but never used.
test/storage_test.js: line 153, col 28, 'err' is defined but never used.
test/storage_test.js: line 492, col 55, 'err' is defined but never used.

test/tokbox_test.js: line 116, col 29, 'options' is defined but never used.
test/tokbox_test.js: line 116, col 18, 'sessionId' is defined but never used.
test/tokbox_test.js: line 144, col 47, 'info' is defined but never used.
test/tokbox_test.js: line 178, col 28, 'info' is defined but never used.
test/tokbox_test.js: line 197, col 28, 'info' is defined but never used.
test/tokbox_test.js: line 295, col 40, 'err' is defined but never used.

loop/index.js: line 643, col 35, 'err' is defined but never used.
loop/index.js: line 682, col 53, 'record' is defined but never used.
loop/index.js: line 742, col 31, 'err' is defined but never used.

loop/tokbox.js: line 130, col 21, 'serverURL' is defined but never used.

loop/websockets.js: line 243, col 50, 'transition' is defined but never used.
loop/websockets.js: line 282, col 60, 'key' is defined but never used.

loop/storage/redis.js: line 26, col 21, 'deleted' is defined but never used.
loop/storage/redis.js: line 203, col 52, 'res' is defined but never used.
loop/storage/redis.js: line 203, col 47, 'err' is defined but never used.
loop/storage/redis.js: line 334, col 52, 'res' is defined but never used.
loop/storage/redis.js: line 334, col 47, 'err' is defined but never used.

50 errors
make: *** [jshint] Error 2
```


Expected results:
:shrug:

It was presumably preffed off for a reason, and most of these probably don't matter, although I'm slightly concerned that we're throwing away error objects:

'err' is defined but never used.
(Reporter)

Comment 1

5 years ago
```
$ make lint | grep "\'err\'"

test/functional_test.js: line 1041, col 27, 'err' is defined but never used.
test/functional_test.js: line 1052, col 27, 'err' is defined but never used.
test/functional_test.js: line 1183, col 31, 'err' is defined but never used.
test/functional_test.js: line 1209, col 31, 'err' is defined but never used.
test/functional_test.js: line 1270, col 31, 'err' is defined but never used.
test/index_test.js: line 383, col 27, 'err' is defined but never used.
test/middlewares_test.js: line 57, col 21, 'err' is defined but never used.
test/storage_test.js: line 122, col 73, 'err' is defined but never used.
test/storage_test.js: line 124, col 24, 'err' is defined but never used.
test/storage_test.js: line 136, col 73, 'err' is defined but never used.
test/storage_test.js: line 138, col 24, 'err' is defined but never used.
test/storage_test.js: line 149, col 73, 'err' is defined but never used.
test/storage_test.js: line 151, col 24, 'err' is defined but never used.
test/storage_test.js: line 153, col 28, 'err' is defined but never used.
test/storage_test.js: line 492, col 55, 'err' is defined but never used.
test/tokbox_test.js: line 295, col 40, 'err' is defined but never used.
loop/index.js: line 643, col 35, 'err' is defined but never used.
loop/index.js: line 742, col 31, 'err' is defined but never used.
loop/storage/redis.js: line 203, col 47, 'err' is defined but never used.
loop/storage/redis.js: line 334, col 47, 'err' is defined but never used.
```
Whiteboard: [qa+]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 999715
OK.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.