Closed Bug 1042304 Opened 6 years ago Closed 6 years ago

[B2G][Dialer] When creating a new contact from an unknown phone number, adding a photo from the gallery will cause apps to be LMK

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 affected)

RESOLVED WORKSFORME
blocking-b2g 2.0+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- affected

People

(Reporter: dharris, Assigned: gsvelto)

References

()

Details

(Keywords: regression, Whiteboard: [2.0-flame-test-run-3])

Attachments

(1 file)

Attached file DialerOOM.txt
Description:
When the user is creating a new contact from an unknown number in the dialer app, then adds a picture to the contact being created, the Dialer app will be closed because of OOM

Prerequisite: Have an unknown number in the call logs. Have at least 1 photo in the gallery.

Repro Steps:
1) Update a Flame to Build ID: 20140721000201
2) Open Dialer App> Call Logs> Long press on unknown number
3) Select "Create New Contact"> Tap add picture> Select Gallery
4) Select a picture> Tap done> Observe

Actual:
The Dialer app is LMK'ed

Expected:
The photo is correctly added to the contact and no apps are closed

Flame 2.0

Environmental Variables:
Device: Flame 2.0
Build ID: 20140721000201
Gaia: 8cb1a949f2e9650bb2c5598e78a6f24a58bbaf97
Gecko: 4bd4b0ae7bbe
Version: 32.0a2 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
 
Keywords: OOM, Crash, LMK, Close, Gallery, Contacts, Add, Photograph, Picture

Repro frequency: 60%
Link to failed test case: https://moztrap.mozilla.org/manage/case/2217/
See attached: Logcat, Video - http://youtu.be/Dvd-y-BIwOY
I was unable to check this issue on Flame 2.1 (273 mb), Buri 2.1, or Open C 2.1 due to bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1041510


Flame 2.1 (273 mb)

Environmental Variables:
Device: flame 2.1
BuildID: 20140721062116
Gaia:
Gecko: 0dc711216018
Version: 33.0a1
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Buri 2.1

v2.1 Environmental Variables:
Device: Buri Master
BuildID: 20140721062116
Gaia: Unknown
Gecko: 0dc711216018
Version: 33.0a1
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Open C 2.1

Environmental Variables:
Device: Open_C Master
Build ID: 20140721062116
Gaia: Unknown
Gecko: 0dc711216018
Version: 33.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


This issue does NOT occur on Flame 2.0 (512 mb), Buri 2.0, Open C 2.0, Flame 1.4 (273 mb), Buri 1.4, Open C 1.4, Flame base v122, or Flame base v121-2

The photo is correctly added to the contact and no apps are closed


Flame 2.0 (512 mb)

Environmental Variables:
Device: Flame 2.0
Build ID: 20140721000201
Gaia: 8cb1a949f2e9650bb2c5598e78a6f24a58bbaf97
Gecko: 4bd4b0ae7bbe
Version: 32.0a2 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140721003002
Gaia: 8cb1a949f2e9650bb2c5598e78a6f24a58bbaf97
Gecko: 4bd4b0ae7bbe
Version: 32.0a2 (2.0) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Open C 2.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140721000201
Gaia: 8cb1a949f2e9650bb2c5598e78a6f24a58bbaf97
Gecko: 4bd4b0ae7bbe
Version: 32.0a2 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Flame 1.4 (273 mb)

Environmental Variables:
Device: Flame 1.4
Build ID: 20140721000201
Gaia: 621d152f89347c79619aa909ad62cc2ac9d3ab5b
Gecko: 83b7be7fb33f
Version: 30.0 (1.4)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Buri 1.4

Environmental Variables:
Device: Buri 1.4
Build ID: 20140721000201
Gaia: 621d152f89347c79619aa909ad62cc2ac9d3ab5b
Gecko: 83b7be7fb33f
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Open C 1.4

Environmental Variables:
Device: Open_C 1.4
Build ID: 20140721000201
Gaia: 621d152f89347c79619aa909ad62cc2ac9d3ab5b
Gecko: 83b7be7fb33f
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Flame base v122

Environmental Variables:
Device: Flame 1.3 (273MB)
Build ID: 20140616171114
Gaia: e1b7152715072d27e0880cdc6b637f82fa42bf4e
Gecko: e181a36ebafaa24e5390db9f597313406edfc794
Version: 28.0 (1.3)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0


Flame base v121-2

Environmental Variables:
Device: Flame 1.3 (273MB)
Build ID: 20140610200025
Gaia: e106a3f4a14eb8d4e10348efac7ae6dea2c24657
Gecko: b637b0677e15318dcce703f0358b397e09b018af
Version: 28.0 (1.3)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]:

This is a regression from 1.4 and is s serious break in functionality. The user should always be able to add a contact with a picture from a phone number. Nominating 2.0?
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
blocking-b2g: 2.0? → 2.0+
Blocker just pops out after sprint planning.
Can we get dialer team to investigate this issue?
Flags: needinfo?(anthony)
I've got some spare cycles, I'll have a look right away.
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Flags: needinfo?(anthony)
Component: Gaia::Dialer → Gaia::Contacts
I am unable to reproduce this on the latest build (and the reporter's build) when running 319 MB.  I had the reporter attempt to reproduce this as well and he could not.  Dialer never OOM when following the steps in comment 0.

Environmental Variables:
Device: Flame 2.0
BuildID: 20140724081209
Gaia: 68226b3fd4eba752307daa5e917238bde253f5ab
Gecko: 8b920340ee28
Version: 32.0 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Issue no longer repros with the new 319 mem, leaving open for perf investigation
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
I've tested this on my Hamachi on both v2.0 and master and cannot reproduce so closing as WORKSFORME, reopen if this crops up again.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.