[B2G][Email] UI is showing through while transitioning between Email settings

RESOLVED DUPLICATE of bug 1042104

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1042104
4 years ago
4 years ago

People

(Reporter: Josh Schmitt [Joshs], Unassigned)

Tracking

({regression})

Trunk
mozilla33
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8460543 [details]
log.txt

Description:
Email UI is showing while transitioning through Email settings.

Repro Steps:
1) Update a Flame to 20140722040212
2) Launch Email app
3) Sign into valid Email
4) Select the Hamburger icon
5) Select on the Gear icon
6) Select the current signed in Email

Actual:
The UI is being seen while transitioning through Email settings.

Expected:
The UI does not show while Email settings is transitioning.

Environmental Variables:
Device: Flame Master
Build ID: 20140722040212
Gaia: e423c3be8d19c9a8a5ae2571f499c36dc6b0df89
Gecko: 6f702709fab6
Version: 34.0a1 (Master)
Firmware Version: v122

User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Notes:
Repro frequency: 100%
See attached: https://www.youtube.com/watch?v=Lz9rXsYAGsg and logcat
(Reporter)

Comment 1

4 years ago
Issue occurs on both 273mb and also 512mb.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
qawanted to do the branch checks.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qawanted
This issue DOES occur on Buri 2.1 master.

Observed: While transitioning between email account settings, previous email UI is shown during transition.

Device: Buri
Build ID: 20140723121905
Gaia: 15c84c943e41ad834640a45e1e1c2ac804168af7
Gecko: 30907d52c4c2
Version: 34.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

-------

This issue does NOT occur on Flame 2.0.

Observed: While transitioning between email account settings, previous email UI is not shown during transition.

Device: Flame
Build ID: 20140723115107
Gaia: 01382a55939b41067e780c61b46e4390576b7f09
Gecko: 2cc680dfda87
Version: 32.0 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
Flags: needinfo?(jmitchell)
Keywords: qawanted
waiting for nom decision before adding regression-window tag (I don't agree with the nom, but the nommer didn't say why they felt it was a blocking issue so it is difficult to say).
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Keywords: regression
(In reply to Joshua Mitchell [:Joshua_M] from comment #5)
> waiting for nom decision before adding regression-window tag (I don't agree
> with the nom, but the nommer didn't say why they felt it was a blocking
> issue so it is difficult to say).

My guess is this was nomed because it's a really ugly transition that our visual design team would likely argue to block on. I can needinfo UX to weigh in here to see if they agree.
Flags: needinfo?(firefoxos-ux-bugzilla)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+][lead-review+]
Keywords: regressionwindow-wanted

Comment 7

4 years ago
It's ugly and a regression, so together I feel this really ought to block.
Flags: needinfo?(firefoxos-ux-bugzilla)
QA Contact: jmercado
My expectation for this bug is something in the platform/gecko changed, but having a regression range to confirm would help. The email app has not changed how it does the CSS transforms to navigate between z-indexed cards since 2.0.
Seems to be caused by bug 1022612.

Mozilla-inbound Regression Window

Last Working
Environmental Variables:
Device: Flame Master
BuildID: 20140719062420
Gaia: d839242c2a4a6a445cbd8bc2443acbdf712a19fc
Gecko: 9350909a3401
Version: 33.0a1 (Master) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

First Broken
Environmental Variables:
Device: Flame Master
BuildID: 20140719065518
Gaia: d839242c2a4a6a445cbd8bc2443acbdf712a19fc
Gecko: 24a69de91baa
Version: 33.0a1 (Master) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0





Last Working Gaia / First Broken Gecko - Issue DOES occur
Gaia: d839242c2a4a6a445cbd8bc2443acbdf712a19fc
Gecko: 24a69de91baa

First Broken Gaia /  Last Working Gecko - Issue does NOT occur
Gaia: d839242c2a4a6a445cbd8bc2443acbdf712a19fc
Gecko: 9350909a3401

Gecko Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9350909a3401&tochange=24a69de91baa
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Switching product/component to core/layout to match bug 1022612.
Component: Gaia::E-Mail → Layout
Product: Firefox OS → Core
Target Milestone: --- → mozilla33
Version: unspecified → Trunk
broken by bug 1022612? Robert - can you take a look?
Blocks: 1022612
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Let's try that again (mid-air collision threw me off my game)
Flags: needinfo?(roc)
See if this is fixed by the fix for bug 1042104, which just landed on inbound.
Flags: needinfo?(roc)
QA-wanted to retest this on any Mozilla-Inbound build that posts after 4:00 today ex 2014073016xxxx
(not on pvt website yet)
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qawanted
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #13)
> See if this is fixed by the fix for bug 1042104, which just landed on
> inbound.

Yes, this bug no longer repros in a recent Mozilla-Inbound build

Device: Flame Master
Build ID: 20140730193506
Gaia: b67ddd7d40b52e65199478b8d6631c2c28fdf41d
Gecko: 299094e66ea0
Version: 34.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Flags: needinfo?(roc)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(roc)
Resolution: --- → DUPLICATE
Duplicate of bug: 1042104
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)

Updated

4 years ago
blocking-b2g: 2.1? → ---
You need to log in before you can comment on or make changes to this bug.