crash in libsystem_kernel.dylib@0x15866 (mozilla::ipc::GeckoChildProcessHost::PerformAsyncLaunchInternal)

VERIFIED FIXED in Firefox 34

Status

()

--
critical
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: drno, Assigned: gfritzsche)

Tracking

(Blocks: 1 bug, {crash})

unspecified
mozilla34
All
Mac OS X
crash
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox34 verified)

Details

(Whiteboard: fixed by bug 1041525, crash signature)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-c3fb9e06-34a6-4260-9e61-699c02140722.
=============================================================
(Reporter)

Comment 1

4 years ago
This was after starting todays Nightly (34.0a1 (2014-07-22)), wait for the Plugin to become enabled and then try to place an H264 only call via webrtc-landing/pc_test.html

Comment 3

4 years ago
I saw this with today's Nightly (7-22) but only on OSX, the other two platforms worked for me.  Also only on the build from nightly.mozilla.org and not when I build locally without crashreporter.
Georg -- I know you're fixing crash reporter now.  Can you look at the crash on this bug and tell me if this looks like an issue you're already fixing?
Blocks: 948160
Flags: needinfo?(georg.fritzsche)
(Assignee)

Comment 5

4 years ago
Those look like hang reports (EXC_SOFTWARE / SIGABRT).
If they are, then they are dupes of bug 1041525 - Ethan?
Flags: needinfo?(georg.fritzsche) → needinfo?(ethanhugg)
(Assignee)

Comment 6

4 years ago
Hm, actually they are 34.0a1 crashes, so it can't be bug 1041525 exactly as that one is worked around.
Due to the similar stacks i'm suspecting this has a common cause with bug 1041525.

Comment 7

4 years ago
Here's one from my Mac:
https://crash-stats.mozilla.com/report/index/b2b60a27-194e-43de-af0b-119732140722

So it's probably the same cause.  They happen at the same time while setting up the 264 call.  Monday's build just hung with the wait icon indefinitely, Tuesday's build crashes to desktop.  Both were 100% repeatable for me.
Flags: needinfo?(ethanhugg)
(In reply to Georg Fritzsche [:gfritzsche] from comment #6)
> Hm, actually they are 34.0a1 crashes, so it can't be bug 1041525 exactly as that one is worked around.
> Due to the similar stacks i'm suspecting this has a common cause with bug 1041525.

Georg -- Since this looks like it has a common cause with bug 1041525, I think it makes sense to assign this to you.
Assignee: nobody → georg.fritzsche
(Assignee)

Comment 9

4 years ago
This should be fixed by bug 1041525.

We're crashing on the std::vector<std::string>::push_back() line here:
http://hg.mozilla.org/mozilla-central/annotate/63f44b4968c2/ipc/glue/GeckoChildProcessHost.cpp#l668

Bug 1041525 disabled the crashreporter initialization, so we end up requesting an - uninitialized - pipe identifier (char*):
http://hg.mozilla.org/mozilla-central/annotate/63f44b4968c2/toolkit/crashreporter/nsExceptionHandler.cpp#l2666
http://hg.mozilla.org/mozilla-central/annotate/63f44b4968c2/toolkit/crashreporter/nsExceptionHandler.cpp#l279
... and end up constructing a std::string from it.
Depends on: 1041525
Whiteboard: [openh264-uplift]
Can you verify this is now fixed on inbound?  (or if you believe it is, close and if we're wrong it will be reopened or a new bug filed.)  Thanks.
Flags: needinfo?(georg.fritzsche)
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(georg.fritzsche)
Resolution: --- → FIXED
Whiteboard: [openh264-uplift] → [openh264-uplift] fixed by bug 1041525
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1042215
Target Milestone: --- → mozilla34

Updated

4 years ago
Whiteboard: [openh264-uplift] fixed by bug 1041525 → fixed by bug 1041525
Nils, is this something you could verify for us? If not maybe Alexandra can take it on. Thanks!
Flags: needinfo?(drno)
QA Contact: drno
Flags: qe-verify+
(Reporter)

Comment 13

4 years ago
In all my manual tests I have not encountered a crash again. So I think this seems to be fixed.
status-firefox34: --- → verified
Flags: needinfo?(drno)
Marking this bug as verified based on comment 13.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.