If not typed the last "/", the page is not loaded (redirects not being followed)

VERIFIED FIXED in M9

Status

()

P2
major
VERIFIED FIXED
19 years ago
2 years ago

People

(Reporter: teruko, Assigned: rpotts)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
If you type "http://home.netscape.com/ja" instead of "http://home.netscape.com/ja/" in the URL
location bar, the page is not loaded.

Step of reproduce
1. Launch Apprunner
2. type "http://home.netscape.com"   this page is loaded correctly.
3. add "/ja"  after "http://home.netscape.com"
This page is not loaded correctly even though in the Dos Prompt console, the message "http://home.netscape.com/ja is
loaded correctly" shows.

If you type "http://home.netscape.com/ja/", the page is loaded correctly.

I tested "http://home.netscape.com/fr" "http://home.netscape.com/zh/cn", and "http://home.netscape.com/zh/tw"
I got the same results as when I type "http://home.netscape.com/ja".

Tested 7-21-16-NECKO Win32 build.  This does not happen in 7-22-08-M9 Win32 build.
(Reporter)

Updated

19 years ago
Priority: P3 → P2
Summary: If not typed the last "/", the page is not loaded → If not typed the last "/", the page is not loaded
Target Milestone: M9

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 1

19 years ago
This is a redirect issue. I will look into it (cc'ing Rick if he wants to
volunteer :)

Updated

19 years ago
Summary: If not typed the last "/", the page is not loaded → If not typed the last "/", the page is not loaded (redirects not being followed)

Updated

19 years ago
Blocks: 10730

Updated

19 years ago
Assignee: gagan → rpotts
Status: ASSIGNED → NEW
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

19 years ago
If the server did not send an entity along with the 302 status code necko would
not handle the redirect.

This should work now :-)
-- rick

Comment 3

19 years ago
*** Bug 10851 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
this works with 7/31 builds, marking verified

Comment 5

19 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
You need to log in before you can comment on or make changes to this bug.