Closed Bug 1042435 Opened 6 years ago Closed 6 years ago

Face detection circles aren't shown for front camera

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: bhargavg1, Unassigned)

References

Details

(Whiteboard: [caf priority: p2][CR 696642])

See that for front camera we dont show face detection circles even though the HAL/Gecko process these events

From logs

E/QCamera2HWI(  228): [KPI Perf] static void qcamera::QCamera2HardwareInterface::metadata_stream_cb_routine(mm_camera_super_buf_t*, qcamera::QCameraStream*, void*): PROFILE_NUMBER_OF_FACES_DETECTED 1
E/GonkCamera( 1068): Camera detected 1 face(s)
E/GonkCamera( 1068): Camera face[0] appended: id=1, score=72, bound=(-372, -167)-(71, 424)
E/GonkCamera( 1068):     Left eye detected at (-200, 200)
E/GonkCamera( 1068):     Right eye detected at (-185, -25)
E/GonkCamera( 1068):     Mouth detected at (-19, 112)
E/GonkCamera( 1068): DOM OnFacesDetected 1 face(s)
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.0?
Whiteboard: [CR 696633] → [caf priority: p1][CR 696633]
Whiteboard: [caf priority: p1][CR 696633] → [caf priority: p2][CR 696633]
Can we reproduce this on Flame?
Keywords: qawanted
No. Flame front camera does have face tracking because the HW doesn't support focus regions.
(In reply to Diego Marcos [:dmarcos] from comment #3)
> No. Flame front camera does have face tracking because the HW doesn't
> support focus regions.

I meant Flame front DOES NOT support face tracking
If any camera support both face tracking + focus regions the feature will be available automatically
If Face Detection and Focus regions are both available, face tracking will be enabled automatically. Otherwise it is disabled. 

Bhargav: Can you confirm if QRD supports focus regions on front camera?
Flags: needinfo?(bhargavg1)
I don't have a QRD device but my guess is that either face tracking or focus regions are not available for the front camera so the feature is not available.
On flame we could paint the circles around the faces but we would not be able to focus on them. It would be misleading for the user.
Keywords: qawanted
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
Clearing the nom on the invalid bug. Comment 6 has justification.
blocking-b2g: 2.0? → ---
Flags: needinfo?(bhargavg1)
Whiteboard: [caf priority: p2][CR 696633] → [caf priority: p2][CR 696642]
Hema -- we confirmed that 8x10 QRD has fixed focus sensor so it won't have face detection circles. We are trying to verify on 8926.
On 8x26 targets the front camera focus mode is fixed and so focus region in not supported.
You need to log in before you can comment on or make changes to this bug.