cannot connect to local IP unless a new tab is opened

RESOLVED DUPLICATE of bug 1041511

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1041511
4 years ago
4 years ago

People

(Reporter: Marc Auslander, Unassigned)

Tracking

33 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
The symptom is that all local lan addresses show server not found.  These are specified as ip addresses rather than names.  These include my modem, my router, and my local server.  Addresses are for example http://192.168.100.1 (modem).

Names in hosts which resolve to local addresses also fail, in this case by going to a search for the name.

Note that accessing internet servers by ip address works correctly.

Could this be related to the fact that reverse lookups of these addresses of course fail?

This is happening always on the linux version of firefox, including in safe mode.  It happens at random on the windows version, and restarting clears the problem, so it's impossible to check for safe mode on windows.

I need pointers as to how to get more information.

Comment 1

4 years ago
Weird. Testing on Aurora on Linux here. If I attempt to connect to my modem/router at http://192.168.1.1 with a webpage open I get a server not found error. However, if I do so from a new tab it works fine.

STR:
1) create new profile
2) create new tab
3) go to http://example.com
4) go to http server on local IP in same tab
5) expected -> go to page
   actual   -> "server not found"

Loads fine for me on 32b1 but fails on 33a2 (current Aurora). IP opens fine in a new tab.

Is this the same for you? Test for both Windows and Linux if you can, please.
OS: Windows 7 → All
Hardware: x86_64 → All
(Reporter)

Comment 2

4 years ago
Yes!  Thanks for diagnosing the apparent intermittent nature of the bug.  I see this on both linux and windows.  Looks like you've found the regression window as well.

IIRC 33 has the new certificate library.  Could this be related?

Updated

4 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: server not found for local lan addresses → cannot connect to local IP unless a new tab is opened
Version: 34 Branch → 33 Branch

Comment 3

4 years ago
(In reply to Marc Auslander from comment #2)
> IIRC 33 has the new certificate library.  Could this be related?

That supposedly went live in 31, also, my test IP isn't over HTTPS, so no cert in question.
(Reporter)

Comment 4

4 years ago
To be a little more specific, you can visit the local address if a tab contains about:home, about:newtab, or a page from a local address.  If the tab contains a page from the internet, you cannot then visit a local page.

Comment 5

4 years ago
I just retested with a current nightly and again with the following build:
https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/sworkman@mozilla.com-8e3a63e3afd7/

Fails on nightly but works in that build which contains the patch for bug 1041511. This bug appears to be a variant of that one so thankfully this has already been investigated and the fix is in the works. Duping.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1041511
You need to log in before you can comment on or make changes to this bug.