Closed Bug 1042502 Opened 6 years ago Closed 6 years ago

No need to removeObserver in Snippets

Categories

(Firefox for Android :: General, defect)

x86_64
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 34
Tracking Status
firefox33 --- verified
firefox34 --- verified
fennec 33+ ---

People

(Reporter: mfinkle, Assigned: mfinkle)

References

Details

Attachments

(1 file)

Attached patch snippet-fix v0.1Splinter Review
In fact, trying to remove the observer will throw an error:
JavaScript Error: "NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]" {file: "/components/Snippets.js" line: 389}]

We use component category now, so we never need to addObserver anymore.
Attachment #8460738 - Flags: review?(margaret.leibovic)
Comment on attachment 8460738 [details] [diff] [review]
snippet-fix v0.1

Review of attachment 8460738 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the follow-up.
Attachment #8460738 - Flags: review?(margaret.leibovic) → review+
Assignee: nobody → mark.finkle
Blocks: 964511
https://hg.mozilla.org/mozilla-central/rev/73b61749c377
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 34
Comment on attachment 8460738 [details] [diff] [review]
snippet-fix v0.1

Approval Request Comment
[Feature/regressing bug #]:bug 964511
[User impact if declined]:No snippets
[Describe test coverage new/current, TBPL]: Works fine in Nightly
[Risks and why]: none
[String/UUID change made/needed]: none
Attachment #8460738 - Flags: approval-mozilla-aurora?
Duplicate of this bug: 1043851
Attachment #8460738 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed using the steps from Bug 1043851. Snippets are displayed on both builds, Nightly and Aurora.
Builds:
Aurora 33.0a2 (2014-07-29)
Nightly 34.0a1 (2014-07-29)

Device: Asus Transformer Pad TF300T (Android 4.2.1)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.