After upgrading guest additions in the dev VM, many packages become 'autoremove'able' but are not removed

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: lgp171188, Assigned: lgp171188, Mentored)

Tracking

Details

(Assignee)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Create a development environment following the steps given in the "Getting started" section of the fjord docs on readthedocs.org. Upgrading the guest additions to match the installed version of VirtualBox, 


Actual results:

A lot of packages that were originally installed for the default guest additions in the image become unnecessary and "autoremove"able, i.e., they show up as unused packages that can be removed whenever any package is installed or removed after that.


Expected results:

Since most of the listed "autoremove"able packages are related to X server support for the guest additions and the development VM doesn't use X server, they can be safely removed. This has to be fixed in the vagrant_provision.sh
(Assignee)

Updated

4 years ago
Summary: After upgrading guest additions many packages become 'autoremove'able' but are not removed → After upgrading guest additions in the dev VM, many packages become 'autoremove'able' but are not removed
One of the things I was trying to do was reduce the amount of time and network bandwidth it took to get a working development environment going. So I didn't have it do updates or other things like that.

I'm not sure it matters a lot, but if it reduces the size of the vm on disk, that'd be a good thing. What other things would this affect?
We talked about this on IRC and I think my current feeling is that it's worth doing. It cleans up the vm a bit and shouldn't cause any problems. If it turns out to be a terrible idea for some bizarre unforeseen reason, we can always remove the code in question.

Changing this to be a mentored bug. Assigning it.
Assignee: nobody → lgp171188
Mentor: willkg
Status: UNCONFIRMED → NEW
Ever confirmed: true
PR: https://github.com/mozilla/fjord/pull/325

Landed in master in: https://github.com/mozilla/fjord/commit/3e607a5d

This only affects building dev environments, so I'm going to mark it as FIXED now.

Thank you!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.