Address bar search doesn't work for single words.

RESOLVED DUPLICATE of bug 693808

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 693808
4 years ago
4 years ago

People

(Reporter: Ben, Unassigned)

Tracking

30 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

Type a single word into the address bar. It breaks with any word but for sake of example lets go with 'banana'.


Actual results:

The following message is displayed in the browser.

Network Error (dns_server_failure)

Your request could not be processed because an error occurred contacting the DNS server.
The DNS server may be temporarily unavailable, or there could be a network problem.

For assistance, contact your network support team. 


Expected results:

I expected to see Google search results for bananas. 

If I type in two words, for example 'banana hammock' (warning, close your eyes), the search functions normally. 

Additional info - not sure if this is useful but I use Mac OS 10.9.4.

Comment 1

4 years ago
Good news, we just fixed this! Bad news, it'll take a while until the version with the fix is released - in the meantime, you could use the Aurora channel (https://aurora.mozilla.org/).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 693808
You need to log in before you can comment on or make changes to this bug.