Closed Bug 1042628 Opened 8 years ago Closed 7 years ago

Firefox quits unexpectedly after closing the shared window item

Categories

(Core :: WebRTC, defect, P1)

34 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1045482
mozilla34

People

(Reporter: bogdan_maris, Assigned: gcp)

References

Details

Latest Nightly 34.0a1 (buildID: 20140722030201)

STR:
1. Open Firefox
2. Set media.getusermedia.screensharing.enabled to true
3. Open http://queze.net/goinfre/ff_gum_test.htm in a new tab
4. Click Window&Audio
5. Open Window or screen to share dropdown and select something that can be closed afterwards (eg: a folder)
6. Click Share Selected Items
7. Close the item that was shared (eg: a folder)
8. Open Web Console (ctrl/cmd+shift+J)

Expected result: A message appears that says connection lost, an error message or something.

Actual result: Firefox quits after a few seconds without crash report.

Notes:
1. This is Linux only.
2. On Windows the share screen remains stuck on the item that was shared. I left the browser opened with the screen stuck for about 1 hour and I got a crash:

bp-701bebec-cac8-4c7a-9f4b-76b362140723
bp-39af1c3b-46c3-401b-acad-e80122140723
bp-e3ff51a3-2f81-4578-a56a-29cef2140723

I can open a new bug for this crashes.

3. On Mac the share screen turns black (which I think should be expected result) but 'Success!' message is still there.
Blocks: 1040061
Bogdan -- Thank for you the bug reports on screen and window sharing!  When you file a bug against screen/window sharing, can you make it block bug 1040061 (that's the meta bug for screen/window sharing in Fx 33).  Thanks!
Flags: needinfo?(bogdan.maris)
gcp or Matt -- Can either of you take/own this bug? It was just found overnight and would block screen/window sharing in Fx 33.
Flags: needinfo?(linuxwolf)
Flags: needinfo?(gpascutto)
Component: General → WebRTC
Product: Firefox → Core
(In reply to Maire Reavy [:mreavy] (Plz needinfo me) from comment #1)
> Bogdan -- Thank for you the bug reports on screen and window sharing!  When
> you file a bug against screen/window sharing, can you make it block bug
> 1040061 (that's the meta bug for screen/window sharing in Fx 33).  Thanks!

Sure thing.
Flags: needinfo?(bogdan.maris)
Assignee: nobody → gpascutto
Flags: needinfo?(linuxwolf)
Flags: needinfo?(gpascutto)
Whiteboard: [sceensharing-uplift]
Priority: -- → P1
Target Milestone: --- → mozilla34
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #0)
> 3. Open http://queze.net/goinfre/ff_gum_test.htm in a new tab

This is now 404.  Is there another test url that can be used to reproduce?
(In reply to Karl Tomlinson (:karlt) from comment #4)
> (In reply to Bogdan Maris, QA [:bogdan_maris] from comment #0)
> > 3. Open http://queze.net/goinfre/ff_gum_test.htm in a new tab
> 
> This is now 404.  Is there another test url that can be used to reproduce?

It hasn't moved, but there was a typo in comment 0: .html not .htm
http://queze.net/goinfre/ff_gum_test.html
SInce this is reported as Linux-only, dup to the X11 error bug
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1045482
Whiteboard: [sceensharing-uplift]
You need to log in before you can comment on or make changes to this bug.