Check if doing an ARMv6 Beta build off the ESR branch is possible

RESOLVED DUPLICATE of bug 1040319

Status

RESOLVED DUPLICATE of bug 1040319
5 years ago
4 years ago

People

(Reporter: kmoir, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
From mobile meeting raised by kbrosnan

Check if doing an ARMv6 Beta build off the ESR branch is possible (this
build would cover 2.2 and ARMv6 users). This requires that the manifest
code for 32b1 to specify API level 9 which was done on the 32 aurora
branch on the 18th. https://bugzilla.mozilla.org/show_bug.cgi?id=1017244
(Reporter)

Comment 1

5 years ago
To clarify this is a test to see it will work for release
(Reporter)

Comment 2

5 years ago
kbrosnan

To clarify I talked to people in releng and they say this is possible without automation by just doing a dev build off someone's laptop.

So this is not to support ESR on beta but test ESR on release?

Also see bug 1042128 where pmoore is investigating the play store dynamics.
Flags: needinfo?(kbrosnan)
This build needs to be signed with the release keys so that it is usable by the Play Store.
Flags: needinfo?(kbrosnan)
(Reporter)

Comment 4

5 years ago
kbrosnan: I'm still wondering about my previous question 

"So this is not to support ESR on beta but test ESR on release?"

Why would we need the release keys so it could be usable for the Play store if we're not going make it available on beta?  The remaining 2.2 market on release is very small, the market for 2.2 on beta is even smaller.
Flags: needinfo?(kbrosnan)
This would be a Beta build of 31 ESR that would be delivered to the Play Store users. The thought is that we would do a test upgrade of the 31b11 ARMv6 and 2.2 users before delivering this to the release population.

I believe we have some slack here because the 32b1 manifest states API 9 (which is Android 2.3) and assuming we do not push an ARMv6 build to the Play Store. Those populations will stay on 31b11. Brad can you confirm that this would be the expected behavior?
Flags: needinfo?(kbrosnan) → needinfo?(blassey.bugs)
Yup. Because the manifest for 32b1 is API level 9 or higher it won't install over 31b11 on 2.2 devices. Also, because we're not putting and ARMv6 build for 32 in the store 32b1 won't install over 31b11 for ARMv6 devices.

One word of caution though, this test 31(esr-like) build needs to go into the store before it's associated 32b build. That doesn't mean we have to block 32b1 on it though, we can do this test for any of the betas.
Flags: needinfo?(blassey.bugs)
(Reporter)

Comment 7

5 years ago
So the original request was to have an ESR on release and now the request is to have an ESR on beta.  Given the very small user population on Armv6 on beta, I don't know that this is the best use of our limited releng people resources.

Would it be sufficient to test with the fake products in the play store as described here?

https://bugzilla.mozilla.org/show_bug.cgi?id=1042128#c2
(In reply to Kim Moir [:kmoir] from comment #7)
> So the original request was to have an ESR on release and now the request is
> to have an ESR on beta.  Given the very small user population on Armv6 on
> beta, I don't know that this is the best use of our limited releng people
> resources.
No, Kevin is asking for one rebuild of 31b11 ARMv6 to be put in the play store along side one of the 32 betas.
(Reporter)

Comment 9

5 years ago
I'm going to mark this bug as dependent on bug 1042128 where Pete is working out the play store logistics
Depends on: 1042128

Updated

5 years ago
Depends on: 1040319
(Reporter)

Comment 10

4 years ago
I think this can be closed as a duplicate of 1036571, the work is done here.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1040319
You need to log in before you can comment on or make changes to this bug.