Closed Bug 10429 Opened 21 years ago Closed 21 years ago

some windows users see hang on startup with necko builds

Categories

(Core :: Networking, defect, P3, critical)

x86
Windows 95
defect

Tracking

()

VERIFIED DUPLICATE of bug 10373

People

(Reporter: chofmann, Assigned: gagan)

Details

console out put might look like like this from jpatel@netscape.com:

*** Registering html library
  Inside the Exit Wizard function...
  DATA IS: ProfileName=necko%ProfileDir=%
  Created nsProfileCore
  Entered Create Profile RoutineEntered Start AppRunner Routine
  Run AppRunner with profile -> necko <-
  Created nsToolkitCore
  JavaScript error: parent is not defined
  URL: file:///C|/PROGRAM
FILES/NETSCAPE/SEAMONKEY/X86REL/res/profile/navigationFi
  nish.xul LineNo: 48


or

** Registering html library

before it hung.  I tried it a number of times and even reinstalled.  Same
results.

paw@netscape.com (Paul Wyskoczka)
my 166mhz win95 lap starts and runs
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/1999-07-23-11-M9-NECK
O/

ok.  I think paw and jpatel were using the same build.
my 166mhz win95 lap starts and runs
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/1999-07-23-11-M9-NECK
O/

ok.  I think paw and jpatel were using the same build.
my 166mhz win95 lap starts and runs
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/1999-07-23-11-M9-NECK
O/

ok.  I think paw and jpatel were using the same build.
my 166mhz win95 lap starts and runs
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/1999-07-23-11-M9-NECK
O/

ok.  I think paw and jpatel were using the same build.
Severity: normal → critical
Target Milestone: M9
If I create a new profile, I get the error Jay sees. On subsequent runs, I see
the error Paul gets.   win95P133 using the same build chofmann runs successfully
on.
Note: the build from two days ago was okay for me.
I create no new profile...  just download, unzip, and start running apprunner
and the browser.
I create no new profile...  just download, unzip, and start running apprunner
and the browser.
see bug 10106
same error message as showing here when creating new profile
apprunner did launch however
when not creating new profile, no error messages on launch
Adding Bhuvan to CC list in case there's anything we can do to help.
I had a bunch of QA testers try the build:
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/1999-07-23-11-M9-NECK
O/

Lots of different results Win 95, 98 and NT were tested:

- only one crashed when NOT creating a new profile.  This was beppe, everyone
else could launch
- some crashes on when creating a new profile
- some did not crash when creating a new profile
- various comments are:
1) gbush
With existing profiles:
NT - Profile Manager UI screwed up/no buttons/not able to access existing
profile (bug from lastweek-10409)
95 - just hang, only talkback loaded per console
98 - same as NT, UI screwed up

With no profile/need to create:
NT   Profile Manager came up, entered data, hung as describe in bug 10429
95    able to create a profile, hang per 10429
98    able to create profile, hang per 10429

2) pmock
I was able to launch the 1999-07-23-11-M9-NECKO build on my Gateway 200mhz PC
running Windows 98.  I can create a new user profile.  After creating the
profile, necko does launch Apprunner successfully.  I do not crash until I open
Messenger and try to expand the list of mail or news folders.

3)esther
Using the Necko build, with Win95:

1.No mozregistry.dat file, let it create the default one = OK (launched and
displayed startup page)
2.No mozregistry.dat file, pointed it to an already created profile= OK
(launched and displayed startup page)
3.Existing mozregistry.dat file so the profile manager didn't even come up=OK
(launched and displayed startup page)


Used a win95 system.  Compaq Deskpro 5133
I am building the latest tree with NECKO flag turned on.
Let us identify the origin of the error. I will update the bug report
accordingly.
My latest NECKO (Debug) build, built 1/2 hour back,  neither hangs up nor
crashes. Does anyone experiencing hangup/crash has a Debug NECKO build....?
Not that I know of. All of the failures have been using the release build linked
to above.
Gagan,

Do you have any updates on this ...?

Bhuvan.
Nope... Never seen a hang/crash on any of my Necko builds (debug only).
Tried the july 26th nightly release build at
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/1999-07-26-18-M9-NECK
O/ and still getting the same behavior, hanging on launch on my win95,P133, 80Mb
Ram machine. I can create profile fine, but hangs when the browser launches.
Non-necko build launches fine.

All I see is "Talkback loaded OK"
I was able to launch and create a profile without any problems using the 26th
nightly build (the url mentioned by paulmac) on my NT box. Also my local
optimized build works fine too. I think this is getting machine specific. Paul,
is it possible to for you to make a summary of the results in a table format or
so. That would help us to identify the troubled platforms/machines.
Meanwhile, I am going to add bunch of dump statements in the local tree to
isolate the problem. Thanks.
I just ran gagan's debug build on my machine without problems. Helps explain why
none of the necko team has run into the problem, since they are all running
debug builds. Here is some kind of chart  of various QA people running the
release builds:

Owner       OS            Make        Proc.        RAM           Launches?
paulmac    win95       packardbell     133          80             NO
elig       winntsp3    HPVectra        233          96             YES
phillip    winntsp4    CompaqDeskPro   200          64             YES
paw        winnt       HPVectra         ?            ?             NO
cpratt     win98          ?            120          32             YES
pmock      win98       Gateway         200           ?             YES
esther     win95       CPQDeskPro      133          32             YES
gbush      win95          ?            200           ?             NO
gbush      winnt          ?            133           ?             NO
gbush      win98          ?            133           ?             NO
sujay      win98        CompaqDeskPro  133          64             YES
beppe      win95        HP Vectra      166          96             NO

I don't see a pattern, seems to fail on different OS's and speeds. I also tried
deleted/creating new profiles and didn't see an effect.
I used a release build built by racham and had no problems running. I did a
directory compare to see what was and wasn't in his build compared to the
release team's build, if that matters, since I can run racham's build but not
the release team's build. The list is below. I also noticed that the build idea
of racham's build (and one I tried from gagan) had the build ID of 070614 as
opposed to 072618.

What are you guys doing different?

Comparing c:\release
       to c:\bhuvan
  BitTest.exe...not in c:\release
  chrome\
    addressbook\...not in c:\bhuvan\chrome\
    content\...not in c:\release\chrome\

    locale\...not in c:\release\chrome\
    messenger\...not in c:\bhuvan\chrome\
    messengercompose\...not in c:\bhuvan\chrome\
    platform\...not in c:\release\chrome\
    skin\...not in c:\release\chrome\
  components\
    Accountservices.dll...not in c:\release\components\
    Accountservices.xpt...not in c:\release\components\
    addrbook.dll...not in c:\bhuvan\components\
    chardetnative.dll...not in c:\release\components\
    emitter.dll...not in c:\bhuvan\components\
    IMGlue.dll...not in c:\bhuvan\components\
    mailnewspublic.xpt...not in c:\bhuvan\components\
    mime.dll...not in c:\bhuvan\components\
    mork.dll...not in c:\bhuvan\components\
    msgbase.dll...not in c:\bhuvan\components\
    msgbase.xpt...not in c:\bhuvan\components\
    msgcompose.dll...not in c:\bhuvan\components\
    msgcompose.xpt...not in c:\bhuvan\components\
    msgdb.dll...not in c:\bhuvan\components\
    msgdb.xpt...not in c:\bhuvan\components\
    msgimap.dll...not in c:\bhuvan\components\
    msglocal.dll...not in c:\bhuvan\components\
    msglocal.xpt...not in c:\bhuvan\components\
    msgnews.dll...not in c:\bhuvan\components\
    msgnews.xpt...not in c:\bhuvan\components\
    msgsearch.xpt...not in c:\bhuvan\components\
    nsIAimBuddy.xpt...not in c:\bhuvan\components\
    nsIAimIM.xpt...not in c:\bhuvan\components\
    nsIAimLocateManager.xpt...not in c:\bhuvan\components\
    nsIAimPrivacy.xpt...not in c:\bhuvan\components\
    nsIAimSession.xpt...not in c:\bhuvan\components\
    nsIIMManager.xpt...not in c:\bhuvan\components\
    spellchecker\...not in c:\bhuvan\components\
    vcard.dll...not in c:\bhuvan\components\
    xpaccount32.dll...not in c:\release\components\
  CoolAdmin.dll...not in c:\bhuvan
  CoolBos.dll...not in c:\bhuvan
  CoolBucky.dll...not in c:\bhuvan
  CoolChat.dll...not in c:\bhuvan
  CoolSocket.dll...not in c:\bhuvan
  CoolUtils.dll...not in c:\bhuvan
  CvtURL.exe...not in c:\release
  DetectCharset.exe...not in c:\release
  DumpColors.exe...not in c:\release
  FilesTest.exe...not in c:\release
  fullsoft.dll...not in c:\bhuvan
  htmlrobot.exe...not in c:\release
  ImageTest.exe...not in c:\release
  master.ini...not in c:\bhuvan
  msgbaseutil.dll...not in c:\bhuvan
  MSVCIRT.DLL...not in c:\bhuvan
  netlib.dll...not in c:\bhuvan
  Netscape\...not in c:\bhuvan
  npmozctl.dll...not in c:\bhuvan
  plugins\...not in c:\release
  PrimitiveTest.exe...not in c:\release
  PropertiesTest.exe...not in c:\release
  ProxyTest.exe...not in c:\release
  rdfcat.exe...not in c:\release
  rdfpoll.exe...not in c:\release
  rebasedlls.exe...not in c:\release
  regExport.exe...not in c:\release
  RegFactory.exe...not in c:\release
  res\
    aim\...not in c:\bhuvan\res\
    mailnews\...not in c:\bhuvan\res\
    MozillaControl.html...not in c:\bhuvan\res\
    network\...not in c:\bhuvan\res\
    profile\
      Account.html...not in c:\release\res\profile\
      navigationFinish.xul...different size
    rdf\
      xpinstall\
      folder-closed.gif...not in c:\bhuvan\res\xpinstall\
      folder-open.gif...not in c:\bhuvan\res\xpinstall\
      package.gif...not in c:\bhuvan\res\xpinstall\
      SoftwareUpdate-Source-1.rdf...not in c:\bhuvan\res\xpinstall\
      SoftwareUpdate.css...not in c:\bhuvan\res\xpinstall\
      SoftwareUpdate.js...not in c:\bhuvan\res\xpinstall\
      SoftwareUpdate.xul...not in c:\bhuvan\res\xpinstall\
      SoftwareUpdates.rdf...not in c:\bhuvan\res\xpinstall\
  SimpleTypeLib.exe...not in c:\release
  StringBundleTest.exe...not in c:\release
  talkback.cnt...not in c:\bhuvan
  talkback.exe...not in c:\bhuvan
  talkback.hlp...not in c:\bhuvan
  TestArray.exe...not in c:\release
  TestAtoms.exe...not in c:\release
  TestAttributes.exe...not in c:\release
  TestAutoLock.exe...not in c:\release
  TestBuffers.exe...not in c:\release
  TestColorNames.exe...not in c:\release
  TestCOM.exe...not in c:\release
  TestCOMFactory.EXE...not in c:\release
  TestCRT.exe...not in c:\release
  TestCSSParser.exe...not in c:\release
  TestCSSPropertyLookup.exe...not in c:\release
  TestCSSScanner.exe...not in c:\release
  TestFactory.exe...not in c:\release
  TestFileInput.exe...not in c:\release
  TestFileInput2.exe...not in c:\release
  TestID.exe...not in c:\release
  TestInterfaceInfo.exe...not in c:\release
  TestLineBreak.exe...not in c:\release
  TestObserverService.exe...not in c:\release
  TestPICS.exe...not in c:\release
  TestPipes.exe...not in c:\release
  TestProtocols.exe...not in c:\release
  TestRect.exe...not in c:\release
  TestServMgr.exe...not in c:\release
  TestSocketInput.exe...not in c:\release
  TestSocketIO.exe...not in c:\release
  TestSocketTransport.exe...not in c:\release
  TestSpaceManager.exe...not in c:\release
  TestThreads.exe...not in c:\release
  TestTXMgr.exe...not in c:\release
  TestUConv.exe...not in c:\release
  TestXPC.exe...not in c:\release
  TestXPTCInvoke.exe...not in c:\release
  UnicharSelfTest.exe...not in c:\release
  urltest.exe...not in c:\release
  viewer.exe...not in c:\release
  Xpcs Registry.dat...not in c:\bhuvan
  Xpcs.dll...not in c:\bhuvan
  xpcshell.exe...not in c:\release
  xpidl.exe...not in c:\release
  Xprt.dll...not in c:\bhuvan
  Xptl.dll...not in c:\bhuvan
  xpt_dump.exe...not in c:\release
  xpt_link.exe...not in c:\release
The way I built the NECKO build (pull_and_build_all) is pretty standard.
Here is the list of env variables that I used.

MOZ_SRC=d:\
MOZ_TOOLS=d:\nstools
JAVA_HOME=d:\nstools
MOZ_OUT=d:\
MOZ_BITS=32
NSPR20=1
MOZILLA_CLIENT=1
MOZ_MEDIUM=1
MOZ_DARK=
VERBOSE=1
CM_BLDTYPE=dbg
MODULAR_NETLIB=1
NGLAYOUT_PLUGINS=1
OS_TARGET=WINNT
STANDALONE_IMAGE_LIB=1
_MSC_VER=1200
NECKO=1


Paul,

Do you know if anyone else tried my (release) build ?
Thanks for your feedback.

Bhuvan.
Looks like we lost cyeh and warren off the cc: list. I'll assume that was
accidental.

I don't know if other people have tried the release build. Grace or paw, can you
try the build Bhuvan pointed to in his e-mail?
Here is the email that I sent to Paul regarding the release build that I had
built. Also, I haven't noticed any uninitialized vars inside the loops in the
path of the hangup/crash. Reports from other QA engineers and feedback from
release team should give some clue. If we can identify a machine that hangs on
my build, we can proceed further to identify the location that is causing the
trouble.

______________________________________________________________________________


The Bhuvan Racham wrote:

  I have a release build with some dump statements.
  You can access it via Network Neighborhood.
  My machine name is Bhuvan. You might need to
  copy NECKO build\win32_o.obj folder onto your machine.
  Run bin\apprunner.exe.


  Inside the Exit Wizard function...
  DATA IS: ProfileName=mozProfile432%ProfileDir=%
  Created nsProfileCore
  Entered Create Profile Routine
  PM:End CreateProfile.
  Entered Start AppRunner Routine
  Run AppRunner with profile -> mozProfile432 <-
  Created nsToolkitCore
  Main : Successfully finished profile activities.
  Doing Startup...
  Creating browser app core
  BrowserAppCore has been created.
  Setting content window
  Components = [xpconnect wrapped nsIXPCComponents]
  Components.classes = [xpconnect wrapped nsIXPCClasses]
  Components.classes[component://netscape/preferences] =
component://netscape/preferences
  browser.startup.page = 1
  startpage = http://www.mozillazine.org/
  Document http://www.mozillazine.org/ loaded successfully
  Document: Done (0.201 secs)

  This is after deleting the mozregistry.dat. The above indicates I had a
successful run of the NECKO build.
  Please let me know how far were you able to go on with this build on the
machines that caused hangup/crash.


  Thanks.

  Bhuvan.
1999-07-26-18-M9-NECKO/ build - still hangs for me on Win95, Win98, WinNT with
the set of console messages below plus:
~\components\msgimap.dll  FAILED with error: error 0
            \msglocal.dll FAILED with error: error 0
            \msgnews.dll  FAILED with error: error 0

Was able to launch successfully with Bhuvan's build on all machines-note that
build # was 1999070614
I don't know why the build ID was like that. The tree I pulled was of
07-26-1999.

What Grace seems to be reporting of (1999-07-26-18-M9-NECKO/ build) is a new
problem. Is release team using any extra flags...?

Anyway, the next build posted by the release team will be an interesting one to
check. May be my build pulled all the right stuff not to cause the problems.

Chris, Do we know when the next NECKO build is coming up....?
still hanging on launch with 072823 necko build on win95. Absolutely nothing in
the console. 072815 non-necko build launches fine.
I'm building a NECKO (release) build. I will share the relavant directories
after adding the dump statements in the path of the problem.
My latest i.e., this morning's (local) NECKO (release) [Network
Neighborhood\\Bhuvan\NECKO build 07-29] creates a profile and launches the
apprunner without any problems. I have added lots of dump statements in the main
apprunner. The dump statements start with "**Necko Testing" as you can notice
from the following.

Here is the complete dos shell activity from the time of typing apprunner at
console (no mozregistry.dat, no component.reg) to the time I closed the
apprunner from menu named File. Please use my build on the machines causing the
problems and let us see how far can we go...?

**Necko Testing : begin : Main
**Necko Testing : begin : SetupRegistry
register filter service
*** Registering html library
**Necko Testing : end   : SetupRegistry
**Necko Testing : begin : Get ProfileManager service
**Necko Testing : end   : Get ProfileManager service
**Necko Testing : begin : Start profile service and count profiles
**Necko Testing : end   : Start profile service and count profiles
**Necko Testing : begin : Start commandline service
**Necko Testing : end   : Start commandline service
**Necko Testing : begin : Initialize commandline service
**Necko Testing : end   : Initialize commandline service
**Necko Testing : begin : Get Prefs service
**Necko Testing : end   : Get Prefs service
**Necko Testing : begin : Get Appshell service
**Necko Testing : end   : Get Appshell service
**Necko Testing : begin : Initialize Appshell service
**Necko Testing : end   : Initialize Appshell service
**Necko Testing : begin : Get Appcores service
**Necko Testing : end   : Get Appcores service
**Necko Testing : begin : Profiles Stuff
**Necko Testing : begin : Check Preg Cookie
**Necko Testing : end   : Check Preg Cookie
**Necko Testing : begin : Get Preg Pref
**Necko Testing : end   : Get Preg Pref
**Necko Testing : begin : Start Profile Appshell (window)
**Necko Testing : end   : Start Profile Appshell (window)
**Necko Testing : begin : Run Profile Appshell (window)
Inside the Exit Wizard function...
DATA IS: ProfileName=mozProfile%ProfileDir=%
Created nsProfileCore
Entered Create Profile RoutineEntered Start AppRunner Routine
Run AppRunner with profile -> mozProfile <-
Created nsToolkitCore
**Necko Testing : end   : Run Profile Appshell (window)
**Necko Testing : end   : Profiles Stuff
**Necko Testing : begin : Read user prefs
**Necko Testing : end   : Read user prefs
**Necko Testing : begin : Get cookie service
**Necko Testing : end   : Get cookie service
**Necko Testing : begin : Create browser window
**Necko Testing : end   : Create browser window
**Necko Testing : begin : Get Wallet service
**Necko Testing : end   : Get Wallet service
**Necko Testing : begin : Dispaly browser window
Doing Startup...
Creating browser app core
BrowserAppCore has been created.
Setting content window
Components = [xpconnect wrapped nsIXPCComponents]
Components.classes = [xpconnect wrapped nsIXPCClasses]
Components.classes[component://netscape/preferences] =
component://netscape/preferences
browser.startup.page = 1
startpage = http://www.mozillazine.org/
Document http://www.mozillazine.org/ loaded successfully
Document: Done (0.24 secs)
BrowserNewWindow();
New Browser Window
BrowserOpenWindow();
Open File or Location...
BrowserReload();
Send Page
BrowserEditPage(window.content.location.href);
Edit Page
;
Print Setup...

Print Preview
BrowserPrint()
Print...
BrowserClose();
Close
BrowserExit();
Quit
MsgNewMessage();
Mail Message
BrowserNewEditorWindow();
Blank Window
BrowserNewWindow();
Page Using Template
BrowserNewWindow();
Page using Draft
BrowserReload();
Go Offline
BrowserReload();
Synchronize
Exiting
**Necko Testing : end   : Dispaly browser window
**Necko Testing : begin : Shutdown Apprunner
**Necko Testing : end   : Shutdown Apprunner
**Necko Testing : begin : Shutdown other services
**Necko Testing : end   : Shutdown other services
**Necko Testing : begin : Shutdown XPCOM
**Necko Testing : end   : Shutdown XPCOM
I don't see a NECKO build 07-29 directory that is shared. I see nstools,
cckfolder, dialup, but nothing that says necko
Try refresh on your explorer window.....
I've been told my cpratt, our resident sysadmin, that you need to shorten the
folder name and take out the spaces for my antiquated win95 machine to see it
chofmann asks: when is this going to be fixed? we can't open the tree until we
get resolution on this. it screws up win9* and mac.
Choffman wants to know when this can be fixed...the problems seems to be that
the chrome diretory's path cannot contain any spaces (similar to the problem
that the mac build has).  If you install the x86rel directory straight into the
hardrive, apprunner launches. Many of us had it installed under "Program Files"
in Windows and "Desktop Folder" on the Mac, so it would not work...since those
directories had spaces in their names.
well, that did the trick for me. That will teach me to use our installer to
install the release builds :-)   I'm off and necko'ing
me too.......things up and neckoing
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
so apparently this is a dup of 10373, too bad we had to spin our wheels so long
before figuring this out

*** This bug has been marked as a duplicate of 10373 ***
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
You need to log in before you can comment on or make changes to this bug.