OpenH264 crash in nsAppShell::ProcessNextNativeEvent

RESOLVED DUPLICATE of bug 1041232

Status

()

Core
WebRTC
RESOLVED DUPLICATE of bug 1041232
3 years ago
3 years ago

People

(Reporter: drno, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I enabled and disbaled the plugin a couple of times and placed calls via pc_test.html until I hit a crash which is reproducible. As crashreporter is disabled here a gdb backtrack:

(gdb) bt
#0  0x00007f7d909ebfbd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f7d89ddfe02 in PollWrapper (ufds=0xce1ca0, nfsd=6, timeout_=-1)
    at /home/nohlmeier/src/mozilla-central/widget/gtk/nsAppShell.cpp:44
#2  0x00007f7d85ccdfe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7d85cce0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f7d89de02ff in nsAppShell::ProcessNextNativeEvent (this=0xafc940, mayWait=true)
    at /home/nohlmeier/src/mozilla-central/widget/gtk/nsAppShell.cpp:156
#5  0x00007f7d89db428c in nsBaseAppShell::DoProcessNextNativeEvent (this=0xafc940, mayWait=true, recursionDepth=0)
    at /home/nohlmeier/src/mozilla-central/widget/xpwidgets/nsBaseAppShell.cpp:140
#6  0x00007f7d89db46c6 in nsBaseAppShell::OnProcessNextEvent (this=0xafc940, thr=0x728e60, mayWait=true, recursionDepth=0)
    at /home/nohlmeier/src/mozilla-central/widget/xpwidgets/nsBaseAppShell.cpp:298
#7  0x00007f7d87ed424a in nsThread::ProcessNextEvent (this=0x728e60, aMayWait=true, aResult=0x7ffffbd67a3f)
    at /home/nohlmeier/src/mozilla-central/xpcom/threads/nsThread.cpp:741
#8  0x00007f7d87f141d0 in NS_ProcessNextEvent (aThread=0x728e60, aMayWait=true)
    at /home/nohlmeier/src/mozilla-central/xpcom/glue/nsThreadUtils.cpp:265
#9  0x00007f7d883e3d64 in mozilla::ipc::MessagePump::Run (this=0x712a10, aDelegate=0x701c10)
    at /home/nohlmeier/src/mozilla-central/ipc/glue/MessagePump.cpp:140
#10 0x00007f7d8837fc3b in MessageLoop::RunInternal (this=0x701c10)
    at /home/nohlmeier/src/mozilla-central/ipc/chromium/src/base/message_loop.cc:229
#11 0x00007f7d8837fbcc in MessageLoop::RunHandler (this=0x701c10)
    at /home/nohlmeier/src/mozilla-central/ipc/chromium/src/base/message_loop.cc:222
#12 0x00007f7d8837fb5d in MessageLoop::Run (this=0x701c10)
    at /home/nohlmeier/src/mozilla-central/ipc/chromium/src/base/message_loop.cc:196
#13 0x00007f7d89db4324 in nsBaseAppShell::Run (this=0xafc940)
    at /home/nohlmeier/src/mozilla-central/widget/xpwidgets/nsBaseAppShell.cpp:164
#14 0x00007f7d8b0394b2 in nsAppStartup::Run (this=0xabece0)
    at /home/nohlmeier/src/mozilla-central/toolkit/components/startup/nsAppStartup.cpp:278
#15 0x00007f7d8af2334e in XREMain::XRE_mainRun (this=0x7ffffbd67e10)
    at /home/nohlmeier/src/mozilla-central/toolkit/xre/nsAppRunner.cpp:4013
#16 0x00007f7d8af2366a in XREMain::XRE_main (this=0x7ffffbd67e10, argc=2, argv=0x7ffffbd69308, aAppData=0x7ffffbd68020)
    at /home/nohlmeier/src/mozilla-central/toolkit/xre/nsAppRunner.cpp:4084
#17 0x00007f7d8af238f2 in XRE_main (argc=2, argv=0x7ffffbd69308, aAppData=0x7ffffbd68020, aFlags=0)
    at /home/nohlmeier/src/mozilla-central/toolkit/xre/nsAppRunner.cpp:4298
#18 0x0000000000403a47 in do_main (argc=2, argv=0x7ffffbd69308, xreDirectory=0x657750)
    at /home/nohlmeier/src/mozilla-central/browser/app/nsBrowserApp.cpp:282
#19 0x0000000000403ec6 in main (argc=2, argv=0x7ffffbd69308)
    at /home/nohlmeier/src/mozilla-central/browser/app/nsBrowserApp.cpp:643
Crash-reporter is disabled for the gmp plugin process, otherwise it's enabled.
Whiteboard: [openh264-uplift]
The stack in comment 0 isn't helping much, it only contains rather generic code.
As the crash-reporter is only disabled for crashes in the GMP child process, please submit crash reports.

Are there more specific steps?
Flags: needinfo?(drno)
(Reporter)

Comment 3

3 years ago
No I don't have more specific instructions then I gave in the initial comment. I assume it is some kind of race condition and therefore not super easy to reproduce. I experienced this on 64bit Ubuntu Linux 14.04 with the Nightly.
But every time it crashed I only got a dialog that it could not send a crash report. On Mac I get the crash reports. Because that warning message after a crash was mentioning core dumps I even set the 'ulimit -c unlimited', but with that it would not produce crash reports. And I'm talking here about the generic crash reporter, not specifically about the plugin crash reporter.
As nobody responded to my IRC question what to do, I decided to build and run in gdb. If you can't reproduce let me know either:
a) how do I enable the crash reporter on Linux or
b) what other debug information I need to provide (BTW this was on 64bit Ubuntu 14.04)
Flags: needinfo?(drno)
Strongly believe this is fixed by bug 1041232; reopen or open new if it's seen again
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1041232
Whiteboard: [openh264-uplift]
You need to log in before you can comment on or make changes to this bug.